Bug 192424 - "Autohide" toolbar in full-screen view
Summary: "Autohide" toolbar in full-screen view
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-FullScreen (show other bugs)
Version: 2.3.0
Platform: Ubuntu Packages Linux
: NOR wishlist with 25 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-12 12:35 UTC by DGardner
Modified: 2019-08-13 12:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 6.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DGardner 2009-05-12 12:35:14 UTC
Version:           0.10.0 (using KDE 4.2.2)
OS:                Linux
Installed from:    Ubuntu Packages

In the full-screen mode of the album view, the toolbar is always visible
at the top of the screen. An option to "autohide" this (in the same manner
as the KDE panel, MS Windows task bar, Firefox full-screen mode toolbar,
etc., where the toolbar disappears until the mouse pointer is moved to the
edge of the screen) would make the current "almost full-screen" mode be a
true full-screen mode.

Gwenview has a similar concept, but it also allows a template to be defined
to add a summary of Exif metadata to the toolbar panel. Perhaps it would be
possible to have similar "fly-out" panels added to the digiKam full screen
mode. The existing right-hand metadata panel would be suitable and could
remain the same position and with the same content.

When the toolbars or panels appear briefly in this manner, they can
overlay the image and not cause it to be resized (as in Gwenview, but not
in Firefox).
Comment 1 DGardner 2009-06-15 18:04:45 UTC
I've just used Gwenview 2 under KDE4 and things have changed quite a
bit. The ability to have a summary of the Exif metadata appears to
be gone (along with lots of other features) and in its place is
combined tool-bar and thumbnail-bar that autohides (I preferred the
old one, I think).

Gwenview 1.4 was my preferred tool for sifting out the bad images
before I imported them to digiKam (I never liked ShowFoto--too slow
and buggy) but that has changed now and I'm on the lookout for
something else.

Anyway, take my comments above as referring to Gwenview 1.4, in case
you are wondering what I was referring to above.
Comment 2 caulier.gilles 2011-12-14 10:29:59 UTC
DGardner,

It still valid using digiKam 2.x serie ?

Gilles Caulier
Comment 3 DGardner 2011-12-14 12:02:47 UTC
This is still valid in digiKam 2.3.0 (the latest version to which I have access). In full-screen mode, the tool-bar is always visible and takes up space. This is a particular problem in these days of wide-screen monitors where vertical space is precious.

In 2.3.0, to mitigate this problem, I right-clicked the tool-bar when in full-screen mode and unchecked "Lock Toolbar Positions" and dragged the tool-bar to the left side. However, I had to remove the "digiKam.org" tool-bar button because it made the tool-bar too wide (if I wanted text beside the buttons, I would have turned it on, BTW). Then, I noticed that when positioned on the left, most of the buttons did not work any more (the first three work, but rest become unresponsive). I could not exit full-screen mode using the tool-bar button, for example. I also could not right-click the tool-bar to lock it unless I right-clicked on the tiny handle (now at the top). When horizontal, I could right-click anywhere on the tool-bar to access its context menu. If I set the tool-bar to be floating, then all of the icons disappear. Lastly, the right-click context menu for a full-screen image only works over the image, not off to the side, where I would expect it would still work, as there is nothing else on the screen. (All this on digiKam 2.3.0, KDE 4.7.3, Fedora 16.)

Even if all that were fixed, it would still not be to my liking to just place the tool-bar on the left, as the tool-bar also then appears on the left in non-full-screen mode, and I don't want it there, as the side panels in the album view are already very big.

So, yes, this is still relevant and an auto-hide option would be nice to have. I'd even be happy with an option to just remove the tool-bar when in full-screen mode..... Wait a minute.... I just found a setting under "Editor Window" to hide the tool-bar in full-screen mode. Strange place to hide it for the Album View window, but it works for that, too. The background colour for the full-screen mode in the editor does not match what is set ("Use theme background colour") and is out-of-sync with the background of the thumb-bar in the editor. I never changed the theme and my background is white everywhere except in the editor, where, on changing to full-screen mode, it suddenly turns black.

What doesn't work now is the option to show the thumb-bar. I cannot see that any more at all in the album view.... Wait another minute...the menu option just appeared and when I turned it off and then turned it on again, it started to display the thumb-bar. I didn't notice it because it was greyed out when in thumbnail view. Still, there are some problems with it.

OK, I played about with it for a bit; try this:

1. In the album view, click an image to preview it.

2. Turn on the thumb-bar if not already on.

3. Ctrl+Shift+F to go to full-screen mode.

4. Click the image to go to the thumbnail view.

5. Ctrl+Shift+F to exit full-screen mode.

6. Now, back in the album thumbnail view, the thumb-bar is shown! The menu option to disable it is greyed out.

7. Preview an image and then "un-preview" it and the thumb-bar disappears.

Earlier, I saw in single-image preview mode that the thumb-bar menu option was enabled and checked but the thumb-bar was still not visible in either normal or full-screen mode until I cycled the option in the menu. I couldn't replicate that, though. Perhaps this is some initialisation problem, because this was a new install and I had never touched the menu option before.

To end my ramble, then:

The "Editor Window" setting to hide the tool-bar when in full-screen mode works for the Album View, too, and that's enough for me. The setting needs to be moved or appear in two places, though.

There are problems with the display of the thumb-bar, perhaps related to initial settings for a new install.
Comment 4 caulier.gilles 2011-12-18 10:22:06 UTC
Look comment from Marcel here :

https://bugs.kde.org/show_bug.cgi?id=214107#c1

Gilles Caulier

*** This bug has been marked as a duplicate of bug 214107 ***
Comment 5 caulier.gilles 2019-08-13 12:09:44 UTC
Fixed with bug #214107