Bug 192220 - Crash when visiting http://www.wowwiki.com/API_Frame_RegisterEvent
Summary: Crash when visiting http://www.wowwiki.com/API_Frame_RegisterEvent
Status: RESOLVED DUPLICATE of bug 189373
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 4.2.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-10 13:04 UTC by Christoph Burger-Scheidlin
Modified: 2009-05-10 13:31 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Burger-Scheidlin 2009-05-10 13:04:46 UTC
Version:           4.2.2 (using KDE 4.2.2)
OS:                Linux
Installed from:    Ubuntu Packages

Note: blauzahl on #kde-bugs mentioned that the crash does not occur for her. According to her, she is running 965387khtml & 965387kjs (patched). So this bug could potentially be fixed in svn already.

When visiting  http://www.wowwiki.com/API_Frame_RegisterEvent konqueror crashes. The crash occurs fairly late in the loading process. The website is loaded and shown as it seems without any problems. After that, possibly when loading javascript or such things, the crash happens.

Konqueror gives the following version:
Qt: 4.5.1
KDE: 4.2.3 (KDE 4.2.3)
Konqueror: 4.2.2 (KDE 4.2.2)

This is somewhat strange, I admit, since the package management system yields
4:4.2.3-0ubuntu1~jaunty1~ppa1

so the problem could be in the packages.

Here is the backtrace

Application: Konqueror (konqueror), signal SIGSEGV
0x00007f6e9617ad21 in nanosleep () from /lib/libc.so.6
Current language:  auto; currently c

Thread 1 (Thread 0x7f6e9b28a750 (LWP 19495)):
[KCrash Handler]
#5  0x00007f6e8b3c5537 in millisecondsToTM (milli=1.0730473406347287e+20, utc=true, t=0x7fffa32c1360) at /build/buildd/kde4libs-4.2.3/kjs/date_object.cpp:471
#6  0x00007f6e8b3c8061 in KJS::DateProtoFunc::callAsFunction (this=0x7f6e877f5d40, exec=0x7fffa32c1e60, thisObj=0x7f6e877f5f00, args=@0x7fffa32c1db0)
    at /build/buildd/kde4libs-4.2.3/kjs/date_object.cpp:627
#7  0x00007f6e8b3fa779 in KJS::JSObject::call (this=0x0, exec=0x0, thisObj=0x0, args=@0x0) at /build/buildd/kde4libs-4.2.3/kjs/object.cpp:69
#8  0x00007f6e8b4157f1 in KJS::Machine::runBlock (exec=0x7fffa32c1e60, codeBlock=<value optimized out>, parentExec=0x7fffa32c2950) at codes.def:1192
#9  0x00007f6e8b3f6cdf in KJS::FunctionImp::callAsFunction (this=0x7f6e87892480, exec=0x7fffa32c2950, thisObj=<value optimized out>, args=@0x7fffa32c28a0)
    at /build/buildd/kde4libs-4.2.3/kjs/function.cpp:144
#10 0x00007f6e8b3fa779 in KJS::JSObject::call (this=0x0, exec=0x0, thisObj=0x0, args=@0x0) at /build/buildd/kde4libs-4.2.3/kjs/object.cpp:69
#11 0x00007f6e8b4157f1 in KJS::Machine::runBlock (exec=0x7fffa32c2950, codeBlock=<value optimized out>, parentExec=0x7fffa32c3440) at codes.def:1192
#12 0x00007f6e8b3f6cdf in KJS::FunctionImp::callAsFunction (this=0x7f6e87893980, exec=0x7fffa32c3440, thisObj=<value optimized out>, args=@0x7fffa32c3390)
    at /build/buildd/kde4libs-4.2.3/kjs/function.cpp:144
#13 0x00007f6e8b3fa779 in KJS::JSObject::call (this=0x0, exec=0x0, thisObj=0x0, args=@0x0) at /build/buildd/kde4libs-4.2.3/kjs/object.cpp:69
#14 0x00007f6e8b4157f1 in KJS::Machine::runBlock (exec=0x7fffa32c3440, codeBlock=<value optimized out>, parentExec=0x7fffa32c40b0) at codes.def:1192
#15 0x00007f6e8b3f6cdf in KJS::FunctionImp::callAsFunction (this=0x7f6e87893800, exec=0x7fffa32c40b0, thisObj=<value optimized out>, args=@0x7fffa32c3e80)
    at /build/buildd/kde4libs-4.2.3/kjs/function.cpp:144
#16 0x00007f6e8b3fa779 in KJS::JSObject::call (this=0x0, exec=0x0, thisObj=0x0, args=@0x0) at /build/buildd/kde4libs-4.2.3/kjs/object.cpp:69
#17 0x00007f6e8b4157f1 in KJS::Machine::runBlock (exec=0x7fffa32c40b0, codeBlock=<value optimized out>, parentExec=0x0) at codes.def:1192
#18 0x00007f6e8b3cb379 in KJS::FunctionBodyNode::execute (this=0x2126480, exec=0x7fffa32c40b0) at /build/buildd/kde4libs-4.2.3/kjs/nodes.cpp:928
#19 0x00007f6e8b3fd5e7 in KJS::Interpreter::evaluate (this=0x1e3d5e0, sourceURL=@0x7fffa32c4330, startingLineNumber=1, code=<value optimized out>, codeLength=<value optimized out>, 
    thisV=0x7f6e91e70000) at /build/buildd/kde4libs-4.2.3/kjs/interpreter.cpp:556
#20 0x00007f6e8b3fd6a3 in KJS::Interpreter::evaluate (this=0x0, sourceURL=@0x0, startingLineNumber=0, code=<value optimized out>, thisV=<value optimized out>)
    at /build/buildd/kde4libs-4.2.3/kjs/interpreter.cpp:496
#21 0x00007f6e8baa5c31 in KJS::KJSProxyImpl::evaluate (this=0x1d5c5c0, filename=<value optimized out>, baseLine=1, str=@0x36f05e0, n=<value optimized out>, completion=0x7fffa32c43c0)
    at /build/buildd/kde4libs-4.2.3/khtml/ecma/kjs_proxy.cpp:158
#22 0x00007f6e8b85d223 in KHTMLPart::executeScript (this=0x21eecb0, n=@0x7fffa32c44c0, script=@0x36f05e0) at /build/buildd/kde4libs-4.2.3/khtml/khtml_part.cpp:1367
#23 0x00007f6e8ba8d265 in KJS::ScheduledAction::execute (this=<value optimized out>, window=<value optimized out>) at /build/buildd/kde4libs-4.2.3/khtml/ecma/kjs_window.cpp:2202
#24 0x00007f6e8ba8eca6 in KJS::WindowQObject::timerEvent (this=0x1e72b70) at /build/buildd/kde4libs-4.2.3/khtml/ecma/kjs_window.cpp:2368
#25 0x00007f6e988a5bb3 in QObject::event (this=0x1e72b70, e=0x0) at kernel/qobject.cpp:1082
#26 0x00007f6e97ce9b9d in QApplicationPrivate::notify_helper (this=0x1787430, receiver=0x1e72b70, e=0x7fffa32c4c20) at kernel/qapplication.cpp:4057
#27 0x00007f6e97cf1dea in QApplication::notify (this=0x7fffa32c5140, receiver=0x1e72b70, e=0x7fffa32c4c20) at kernel/qapplication.cpp:4022
#28 0x00007f6e996c48db in KApplication::notify (this=0x7fffa32c5140, receiver=0x1e72b70, event=0x7fffa32c4c20) at /build/buildd/kde4libs-4.2.3/kdeui/kernel/kapplication.cpp:307
#29 0x00007f6e98895dfc in QCoreApplication::notifyInternal (this=0x7fffa32c5140, receiver=0x1e72b70, event=0x7fffa32c4c20) at kernel/qcoreapplication.cpp:610
#30 0x00007f6e988c2eb6 in QTimerInfoList::activateTimers (this=0x178b030) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
#31 0x00007f6e988bf5cd in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:164
#32 0x00007f6e93e7c20a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#33 0x00007f6e93e7f8e0 in ?? () from /usr/lib/libglib-2.0.so.0
#34 0x00007f6e93e7fa7c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#35 0x00007f6e988bf52f in QEventDispatcherGlib::processEvents (this=0x1772b50, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:324
#36 0x00007f6e97d8270f in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
#37 0x00007f6e988946a2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = -1557377392}) at kernel/qeventloop.cpp:149
#38 0x00007f6e98894a6d in QEventLoop::exec (this=0x7fffa32c4ed0, flags={i = -1557377312}) at kernel/qeventloop.cpp:200
#39 0x00007f6e98896d34 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
#40 0x00007f6e9ae7a9e9 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/kdebase-4.2.3/apps/konqueror/src/konqmain.cpp:257
#41 0x00007f6e960f15a6 in __libc_start_main (main=0x400870 <main>, argc=2, ubp_av=0x7fffa32c5bb8, init=0x4008a0 <__libc_csu_init>, fini=<value optimized out>, rtld_fini=<value optimized out>, 
    stack_end=0x7fffa32c5ba8) at libc-start.c:220
#42 0x00000000004007a9 in _start () at ../sysdeps/x86_64/elf/start.S:113
Comment 1 Tommi Tervo 2009-05-10 13:31:00 UTC

*** This bug has been marked as a duplicate of bug 189373 ***