Bug 192151 - konqueror crash when i try to open page
Summary: konqueror crash when i try to open page
Status: RESOLVED DUPLICATE of bug 189373
Alias: None
Product: konqueror
Classification: Applications
Component: kjs (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-09 18:31 UTC by miki
Modified: 2009-05-09 19:03 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description miki 2009-05-09 18:31:53 UTC
Application that crashed: konqueror
Version of the application: 4.2.85 (KDE 4.2.85 (KDE 4.3 Beta1))
KDE Version: 4.2.85 (KDE 4.2.85 (KDE 4.3 Beta1))
Qt Version: 4.5.1
Operating System: Linux 2.6.29-ARCH x86_64

What I was doing when the application crashed:
konqueror crash on http://sports.espn.go.com/sports/tennis/news/story?id=4153353

 -- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
[Current thread is 0 (LWP 11720)]

Thread 5 (Thread 0x7f6e7b529950 (LWP 11725)):
#0  0x00007f6e8e66be6d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f6e8e8dbc37 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#2  0x00007f6e8e8d1819 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f6e8e8dac62 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f6e8e6673b4 in start_thread () from /lib/libpthread.so.0
#5  0x00007f6e8be9889d in clone () from /lib/libc.so.6

Thread 4 (Thread 0x7f6e7a91f950 (LWP 11729)):
#0  0x00007f6e8e66be6d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f6e8e8dbc37 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#2  0x00007f6e8e8d1819 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f6e8e8dac62 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f6e8e6673b4 in start_thread () from /lib/libpthread.so.0
#5  0x00007f6e8be9889d in clone () from /lib/libc.so.6

Thread 3 (Thread 0x7f6e7a11e950 (LWP 11730)):
#0  0x00007f6e8e66be6d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f6e8e8dbc37 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#2  0x00007f6e8e8d1819 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f6e8e8dac62 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f6e8e6673b4 in start_thread () from /lib/libpthread.so.0
#5  0x00007f6e8be9889d in clone () from /lib/libc.so.6

Thread 2 (Thread 0x7f6e7991d950 (LWP 11733)):
#0  0x00007f6e8e66be6d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007f6e8e8dbc37 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#2  0x00007f6e8e8d1819 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007f6e8e8dac62 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007f6e8e6673b4 in start_thread () from /lib/libpthread.so.0
#5  0x00007f6e8be9889d in clone () from /lib/libc.so.6

Thread 1 (Thread 0x7f6e9141f760 (LWP 11720)):
[KCrash Handler]
#5  0x00007f6e80daa934 in millisecondsToTM (milli=<value optimized out>, utc=true, t=0x7fff99468430) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kjs/date_object.cpp:471
#6  0x00007f6e80dabdd9 in KJS::DateProtoFunc::callAsFunction (this=0x7f6e71e71300, exec=0x7fff99468d50, thisObj=0x7f6e7b5d9dc0, args=@0x7fff99468ca0)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kjs/date_object.cpp:627
#7  0x00007f6e80ddcc69 in KJS::JSObject::call (this=0x2, exec=0x0, thisObj=0xcaaa79e6, args=@0x24) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kjs/object.cpp:69
#8  0x00007f6e80df8c53 in KJS::Machine::runBlock (exec=0x7fff99468d50, codeBlock=<value optimized out>, parentExec=<value optimized out>) at codes.def:1192
#9  0x00007f6e80dd9387 in KJS::FunctionImp::callAsFunction (this=0x7f6e79056a00, exec=0x7fff99469740, thisObj=<value optimized out>, args=<value optimized out>)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kjs/function.cpp:144
#10 0x00007f6e80ddcc69 in KJS::JSObject::call (this=0x2, exec=0x0, thisObj=0xcaaa79e6, args=@0x24) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kjs/object.cpp:69
#11 0x00007f6e80df8c53 in KJS::Machine::runBlock (exec=0x7fff99469740, codeBlock=<value optimized out>, parentExec=<value optimized out>) at codes.def:1192
#12 0x00007f6e80dd9387 in KJS::FunctionImp::callAsFunction (this=0x7f6e71da0e00, exec=0x7fff9946a1d0, thisObj=<value optimized out>, args=<value optimized out>)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kjs/function.cpp:144
#13 0x00007f6e80ddcc69 in KJS::JSObject::call (this=0x2, exec=0x0, thisObj=0xcaaa79e6, args=@0x24) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kjs/object.cpp:69
#14 0x00007f6e80df8c53 in KJS::Machine::runBlock (exec=0x7fff9946a1d0, codeBlock=<value optimized out>, parentExec=<value optimized out>) at codes.def:1192
#15 0x00007f6e80daf053 in KJS::FunctionBodyNode::execute (this=0x404c160, exec=0x7fff9946a1d0) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kjs/nodes.cpp:928
#16 0x00007f6e80ddfb8a in KJS::Interpreter::evaluate (this=0x1dfffd0, sourceURL=@0x7fff9946a540, startingLineNumber=0, code=<value optimized out>, codeLength=<value optimized out>, 
    thisV=0x7f6e7b610000) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kjs/interpreter.cpp:556
#17 0x00007f6e80ddfcf3 in KJS::Interpreter::evaluate (this=0xcaaa8152, sourceURL=@0xcaaa79e6, startingLineNumber=36, code=<value optimized out>, thisV=<value optimized out>)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kjs/interpreter.cpp:496
#18 0x00007f6e81494d80 in KJS::KJSProxyImpl::evaluate (this=0x1b60470, filename=) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/khtml/ecma/kjs_proxy.cpp:158
#19 0x00007f6e81255140 in KHTMLPart::executeScript (this=0x1c2e830, filename=@0x7fff9946a720, baseLine=0, n=<value optimized out>, script=<value optimized out>)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/khtml/khtml_part.cpp:1326
#20 0x00007f6e812e5482 in khtml::HTMLTokenizer::scriptExecution (this=0x27c8fd0, str=<value optimized out>, scriptURL=<value optimized out>, baseLine=0)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/khtml/html/htmltokenizer.cpp:501
#21 0x00007f6e812eec89 in khtml::HTMLTokenizer::notifyFinished (this=<value optimized out>) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/khtml/html/htmltokenizer.cpp:2123
#22 0x00007f6e8140eb4f in khtml::CachedScript::checkNotify (this=0x3fa2d20) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/khtml/misc/loader.cpp:389
#23 0x00007f6e8140fa3c in khtml::CachedScript::data (this=0x3fa2d20, buffer=<value optimized out>, eof=<value optimized out>)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/khtml/misc/loader.cpp:381
#24 0x00007f6e8140f6af in khtml::Loader::slotFinished (this=0x1c8eed0, job=0x3ff3cb0) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/khtml/misc/loader.cpp:1455
#25 0x00007f6e81416153 in khtml::Loader::qt_metacall (this=0x1c8eed0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff9946ac70)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/build/khtml/loader.moc:131
#26 0x00007f6e8e9d8db2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#27 0x00007f6e8f021f82 in KJob::result (this=0x2, _t1=0x3ff3cb0) at /home/miki/work1/kdemod-core42/work/kdelibs/src/build/kdecore/kjob.moc:188
#28 0x00007f6e8f0222ff in KJob::emitResult (this=0x3ff3cb0) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kdecore/jobs/kjob.cpp:304
#29 0x00007f6e90288b53 in KIO::SimpleJob::slotFinished (this=0x3ff3cb0) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kio/kio/job.cpp:485
#30 0x00007f6e90289003 in KIO::TransferJob::slotFinished (this=0x3ff3cb0) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kio/kio/job.cpp:962
#31 0x00007f6e902870e1 in KIO::TransferJob::qt_metacall (this=0x3ff3cb0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff9946b080)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/build/kio/jobclasses.moc:343
#32 0x00007f6e8e9d8db2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#33 0x00007f6e9034a131 in KIO::SlaveInterface::dispatch (this=0x33e6380, _cmd=104, rawdata=@0x7fff9946b2d0)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kio/kio/slaveinterface.cpp:175
#34 0x00007f6e90346ac3 in KIO::SlaveInterface::dispatch (this=0x33e6380) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kio/kio/slaveinterface.cpp:91
#35 0x00007f6e903398c2 in KIO::Slave::gotInput (this=0x33e6380) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kio/kio/slave.cpp:322
#36 0x00007f6e9033b93c in KIO::Slave::qt_metacall (this=0x33e6380, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff9946b430)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/build/kio/slave.moc:76
#37 0x00007f6e8e9d8db2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#38 0x00007f6e90256457 in KIO::ConnectionPrivate::dequeue (this=0x27e2b20) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kio/kio/connection.cpp:82
#39 0x00007f6e9025657d in KIO::Connection::qt_metacall (this=0x2dcc970, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x3c12370)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/build/kio/connection.moc:73
#40 0x00007f6e8e9d3408 in QObject::event () from /usr/lib/libQtCore.so.4
#41 0x00007f6e8dc0040d in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#42 0x00007f6e8dc0868a in QApplication::notify () from /usr/lib/libQtGui.so.4
#43 0x00007f6e8f8296e6 in KApplication::notify (this=0x7fff9946bfd0, receiver=0x2dcc970, event=0x32d6910)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.85/kdeui/kernel/kapplication.cpp:307
#44 0x00007f6e8e9c339c in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#45 0x00007f6e8e9c400a in QCoreApplicationPrivate::sendPostedEvents () from /usr/lib/libQtCore.so.4
#46 0x00007f6e8e9ecd83 in ?? () from /usr/lib/libQtCore.so.4
#47 0x00007f6e8a1eb01a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#48 0x00007f6e8a1ee6e0 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#49 0x00007f6e8a1ee87c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#50 0x00007f6e8e9eca0f in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#51 0x00007f6e8dc97aff in ?? () from /usr/lib/libQtGui.so.4
#52 0x00007f6e8e9c1c42 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#53 0x00007f6e8e9c200d in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#54 0x00007f6e8e9c42d4 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#55 0x00007f6e91021b1b in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /home/miki/work1/kdemod-core42/work/kdebase/src/kdebase-4.2.85/apps/konqueror/src/konqmain.cpp:257
#56 0x00007f6e8bdeb55d in __libc_start_main () from /lib/libc.so.6
#57 0x00000000004007c9 in _start ()
Comment 1 Maksim Orlovich 2009-05-09 19:03:32 UTC

*** This bug has been marked as a duplicate of bug 189373 ***