Bug 192135 - Cursor key in drop down list jumps two entries on single click
Summary: Cursor key in drop down list jumps two entries on single click
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 195386 197362 216486 227862 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-05-09 15:30 UTC by Andrey Borzenkov
Modified: 2010-02-20 23:21 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrey Borzenkov 2009-05-09 15:30:04 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

KDE 4.2.85/Qt 4.5.1 as shipped with Mandriva cooker.

Open google.com; enter some search term (like "HDA Intel"). Google displays drop down list of possible completions. If I now try to select from list using cursor keys (key up/down), I can only select every second entry - i.e. it looks like both KeyDown and KeyUp events are interpreted as key press.

This is definite regression to 4.2.2 which worked fine.
Comment 1 Maksim Orlovich 2009-06-05 23:55:20 UTC
*** Bug 195386 has been marked as a duplicate of this bug. ***
Comment 2 Zayed Al-Saidi 2009-06-21 12:48:05 UTC
*** Bug 197362 has been marked as a duplicate of this bug. ***
Comment 3 Andrey Borzenkov 2009-07-25 13:24:55 UTC
Still valid in 4.3RC3 (4.2.98).
Comment 4 newsscott 2009-11-10 19:25:53 UTC
i can confirm this behaviour (Ubuntu 9.10, 4.3.2).
Comment 5 Maksim Orlovich 2009-11-29 17:53:25 UTC
*** Bug 216486 has been marked as a duplicate of this bug. ***
Comment 6 newsscott 2009-12-01 23:35:23 UTC
Workaround: If you need to perform a single step: Press cursor key, but don't release it. Now the selection moves by a single step. It is now possible - while still pressing the cursor key - to select the entry with <Return>.
Comment 7 Germain Garand 2010-02-13 18:04:36 UTC
SVN commit 1089665 by ggarand:

always accept key events here. It's the end of the road : we don't
want notify() to let them percolate to the view as we already went there.

fixes arrow down keypress skipping entries in google's main search page
completion popup.

BUG: 192135

 M  +5 -2      khtmlview.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1089665
Comment 8 Zayed Al-Saidi 2010-02-13 18:16:38 UTC
Thanks, Germain for fixing this bug :) keep it up.
Comment 9 Germain Garand 2010-02-20 23:21:35 UTC
*** Bug 227862 has been marked as a duplicate of this bug. ***