Bug 192035 - akregator crashes on lost connection
Summary: akregator crashes on lost connection
Status: RESOLVED DUPLICATE of bug 191122
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-08 14:19 UTC by hujuice
Modified: 2009-05-18 23:36 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hujuice 2009-05-08 14:19:02 UTC
Version:           4.2.2 (using KDE 4.2.2)
Compiler:          gcc-4.3.2 
OS:                Linux
Installed from:    Gentoo Packages

I experience this issue because I'm connecting to the Internet via ppp, so a non continuous connection.

Every time I disconnect, after a while (the time to search for new feeds?) akregator crashes.

Here's the backtrace (I'm sorry, it's in Italian).
It says that it is an usefulness backtrace, but it has informations at its bottom.

Regards,
HUjuice

Backtrace:
Questo backtrace sembra essere inutile.
Probabilmente i pacchetti che stai utilizzando sono compilati in modo che non si possano creare dei backtrace corretti oppure lo stack frame รจ stato danneggiato seriamente durante il crash.

(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x7f980c068760 (LWP 11159)]
[New Thread 0x41055950 (LWP 25568)]
[New Thread 0x41b49950 (LWP 25567)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x00007f98058fde8e in ?? () from /lib/libc.so.6
[Current thread is 0 (LWP 11159)]

Thread 3 (Thread 0x41b49950 (LWP 25567)):
#0  0x00007f98058fde8e in ?? () from /lib/libc.so.6
#1  0x00007f98058a2f96 in ?? () from /lib/libc.so.6
#2  0x00007f980589fbdb in free () from /lib/libc.so.6
#3  0x00007f98074b86b2 in QByteArray::operator= () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f9807c14ee4 in ?? () from /usr/kde/4.2/lib64/libkdecore.so.5
#5  0x00007f9807c151ea in ?? () from /usr/kde/4.2/lib64/libkdecore.so.5
#6  0x00007f9807c289f4 in ?? () from /usr/kde/4.2/lib64/libkdecore.so.5
#7  0x00007f9807c28d14 in KLocale::translateQt () from /usr/kde/4.2/lib64/libkdecore.so.5
#8  0x00007f980836edfd in ?? () from /usr/kde/4.2/lib64/libkdeui.so.5
#9  0x00007f980759f0d9 in QTranslator::translate () from /usr/lib64/qt4/libQtCore.so.4
#10 0x00007f9807587474 in QCoreApplication::translate () from /usr/lib64/qt4/libQtCore.so.4
#11 0x00007f98075877df in QCoreApplication::translate () from /usr/lib64/qt4/libQtCore.so.4
#12 0x00007f980758b4c0 in QMetaObject::tr () from /usr/lib64/qt4/libQtCore.so.4
#13 0x00007f9806fcedb5 in ?? () from /usr/lib64/qt4/libQtNetwork.so.4
#14 0x00007f9806fc8495 in QHostInfo::fromName () from /usr/lib64/qt4/libQtNetwork.so.4
#15 0x00007f9808909adb in ?? () from /usr/kde/4.2/lib64/libkio.so.5
#16 0x00007f980890a963 in ?? () from /usr/kde/4.2/lib64/libkio.so.5
#17 0x00007f98074aed04 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#18 0x00007f98074b6799 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#19 0x00007f9807248097 in start_thread () from /lib/libpthread.so.0
#20 0x00007f98058f2ccd in clone () from /lib/libc.so.6
#21 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x41055950 (LWP 25568)):
#0  0x00007f98058c5aa1 in nanosleep () from /lib/libc.so.6
#1  0x00007f98058c58c4 in sleep () from /lib/libc.so.6
#2  0x00007f98083ce6c9 in ?? () from /usr/kde/4.2/lib64/libkdeui.so.5
#3  0x00007f98083cf00a in KCrash::defaultCrashHandler () from /usr/kde/4.2/lib64/libkdeui.so.5
#4  <signal handler called>
#5  0x00007f980585e165 in raise () from /lib/libc.so.6
#6  0x00007f980585f4de in abort () from /lib/libc.so.6
#7  0x00007f9805898f87 in ?? () from /lib/libc.so.6
#8  0x00007f980589e19d in ?? () from /lib/libc.so.6
#9  0x00007f98058a0856 in ?? () from /lib/libc.so.6
#10 0x00007f98058a223a in malloc () from /lib/libc.so.6
#11 0x00007f98074f0044 in QString::fromLatin1_helper () from /usr/lib64/qt4/libQtCore.so.4
#12 0x00007f9807c147ab in ?? () from /usr/kde/4.2/lib64/libkdecore.so.5
#13 0x00007f9807c2834c in ?? () from /usr/kde/4.2/lib64/libkdecore.so.5
#14 0x00007f9807c28eed in KLocale::translateQt () from /usr/kde/4.2/lib64/libkdecore.so.5
#15 0x00007f980836edfd in ?? () from /usr/kde/4.2/lib64/libkdeui.so.5
#16 0x00007f980759f0d9 in QTranslator::translate () from /usr/lib64/qt4/libQtCore.so.4
#17 0x00007f9807587474 in QCoreApplication::translate () from /usr/lib64/qt4/libQtCore.so.4
#18 0x00007f98075877df in QCoreApplication::translate () from /usr/lib64/qt4/libQtCore.so.4
#19 0x00007f980758b4c0 in QMetaObject::tr () from /usr/lib64/qt4/libQtCore.so.4
#20 0x00007f9806fcedb5 in ?? () from /usr/lib64/qt4/libQtNetwork.so.4
#21 0x00007f9806fc8495 in QHostInfo::fromName () from /usr/lib64/qt4/libQtNetwork.so.4
#22 0x00007f9808909adb in ?? () from /usr/kde/4.2/lib64/libkio.so.5
#23 0x00007f980890a963 in ?? () from /usr/kde/4.2/lib64/libkio.so.5
#24 0x00007f98074aed04 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#25 0x00007f98074b6799 in ?? () from /usr/lib64/qt4/libQtCore.so.4
#26 0x00007f9807248097 in start_thread () from /lib/libpthread.so.0
#27 0x00007f98058f2ccd in clone () from /lib/libc.so.6
#28 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f980c068760 (LWP 11159)):
#0  0x00007f98058fde8e in ?? () from /lib/libc.so.6
#1  0x00007f98058a2f96 in ?? () from /lib/libc.so.6
#2  0x00007f980589fbdb in free () from /lib/libc.so.6
#3  0x00007f98074f1a0c in QString::free () from /usr/lib64/qt4/libQtCore.so.4
#4  0x00007f98074f1a52 in QString::operator= () from /usr/lib64/qt4/libQtCore.so.4
#5  0x00007f98088e90af in ?? () from /usr/kde/4.2/lib64/libkio.so.5
#6  0x00007f98088ec0f0 in ?? () from /usr/kde/4.2/lib64/libkio.so.5
#7  0x00007f98088ec230 in ?? () from /usr/kde/4.2/lib64/libkio.so.5
#8  0x00007f98088ec49c in KIO::Scheduler::qt_metacall () from /usr/kde/4.2/lib64/libkio.so.5
#9  0x00007f9807596e08 in QMetaObject::activate () from /usr/lib64/qt4/libQtCore.so.4
#10 0x00007f98075930b3 in QObject::event () from /usr/lib64/qt4/libQtCore.so.4
#11 0x00007f98064a13cd in QApplicationPrivate::notify_helper () from /usr/lib64/qt4/libQtGui.so.4
#12 0x00007f98064a760a in QApplication::notify () from /usr/lib64/qt4/libQtGui.so.4
#13 0x00007f9808369f0b in KApplication::notify () from /usr/kde/4.2/lib64/libkdeui.so.5
#14 0x00007f9807585a50 in QCoreApplication::notifyInternal () from /usr/lib64/qt4/libQtCore.so.4
#15 0x00007f98075ac8ae in ?? () from /usr/lib64/qt4/libQtCore.so.4
#16 0x00007f98075a977d in ?? () from /usr/lib64/qt4/libQtCore.so.4
#17 0x00007f980357e4b2 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#18 0x00007f9803581795 in ?? () from /usr/lib/libglib-2.0.so.0
#19 0x00007f9803581c9b in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#20 0x00007f98075a96ef in QEventDispatcherGlib::processEvents () from /usr/lib64/qt4/libQtCore.so.4
#21 0x00007f980651f07f in ?? () from /usr/lib64/qt4/libQtGui.so.4
#22 0x00007f9807584412 in QEventLoop::processEvents () from /usr/lib64/qt4/libQtCore.so.4
#23 0x00007f98075845a5 in QEventLoop::exec () from /usr/lib64/qt4/libQtCore.so.4
#24 0x00007f980758664d in QCoreApplication::exec () from /usr/lib64/qt4/libQtCore.so.4
#25 0x000000000040900e in _start ()
#0  0x00007f98058fde8e in ?? () from /lib/libc.so.6
Comment 1 Dario Andres 2009-05-08 15:02:33 UTC
What is your Qt version ?
Thanks
Comment 2 hujuice 2009-05-08 23:29:27 UTC
Mmmh... maybe it is a Gentoo portage issue?

I didn't see that I've qt-3.3.8b installed and (I don't know why) normal updates don't bring me to the available 4.4.2.
Since all KDE is ok, I didn't see it.

I'm upgrading now. You know that on Gentoo I'll compile everything, so I need a while.
If you agree, we can keep this bug as "suspended" for a dozen of hours, the time to try again.

Regards,
HUjuice
Comment 3 hujuice 2009-05-10 02:10:56 UTC
The problem is still there.
Now I have Qt 4.4.2 and in the last night I had an upgrade to KDE 4.2.3, including Akregator (1.4.2).

And coming back home (Akregator up, Internet connection down), I've found the crash.

I'm not a C programmer, but if you want I can recompile Akregator in a different way, to have more backtrace informations.
Feel free to ask everything you want inside this guide: http://www.gentoo.org/proj/en/qa/backtraces.xml

Regards,
HUjuice
Comment 4 Dario Andres 2009-05-12 17:30:05 UTC
May you read http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports and post a complete backtrace here? Gentoo should have a guide about recompiling packages with debug symbols enabled.
Thanks
Comment 5 hujuice 2009-05-15 01:30:23 UTC
Yes!
It belongs to "my" Gentoo guide.

I'm a bit confused now, here is what I'll do tonight:
CFLAGS="${CFLAGS} -ggdb"
FEATURES="${FEATURES} splitdebug"
LDFLAGS="${LDFLAGS} -s"
("FEATURES" are Gentoo specific? I read that I should activate it here http://www.gentoo.org/proj/en/qa/backtraces.xml)

emerge x11-libs/qt-core x11-libs/qt-gui kde-base/kdelibs sys-libs/glibc
("emerge" = "apt-get install", if you're unfamiliar with Gentoo)

Then, I'll reproduce the crash (it happens always).

If you have more suggestions, I'll follow it.

Regards,
HUjuice
Comment 6 Pino Toscano 2009-05-18 23:36:56 UTC

*** This bug has been marked as a duplicate of bug 191122 ***