Bug 191424 - crash in KJS::DateProtoFunc::callAsFunction
Summary: crash in KJS::DateProtoFunc::callAsFunction
Status: RESOLVED DUPLICATE of bug 189373
Alias: None
Product: konqueror
Classification: Applications
Component: khtml ecma (show other bugs)
Version: SVN
Platform: Unlisted Binaries Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-03 07:11 UTC by miki
Modified: 2009-05-05 17:05 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description miki 2009-05-03 07:11:19 UTC
Title: konqueror crash do not know why

What I was doing when the application crashed:
konqueror crash do not know why

 -- Application and System information:
Application that crashed: konqueror
Version of the application: 4.2.71 (KDE 4.2.71 (KDE 4.3 >= 20090428))
KDE Version: 4.2.71 (KDE 4.2.71 (KDE 4.3 >= 20090428))
Qt Version: 4.5.1
Operating System: Linux 2.6.29-ARCH x86_64

 -- Backtrace:
Application: Konqueror (konqueror), signal: Segmentation fault
[Current thread is 0 (LWP 26776)]

Thread 5 (Thread 0x7fa86c398950 (LWP 26783)):
#0  0x00007fa87f926fed in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fa87fb97c37 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#2  0x00007fa87fb8d819 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007fa87fb96c62 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007fa87f922fc7 in start_thread () from /lib/libpthread.so.0
#5  0x00007fa87d1545dd in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fa86b78e950 (LWP 26787)):
#0  0x00007fa87f926fed in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fa87fb97c37 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#2  0x00007fa87fb8d819 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007fa87fb96c62 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007fa87f922fc7 in start_thread () from /lib/libpthread.so.0
#5  0x00007fa87d1545dd in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fa86af8d950 (LWP 26788)):
#0  0x00007fa87f926fed in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fa87fb97c37 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#2  0x00007fa87fb8d819 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007fa87fb96c62 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007fa87f922fc7 in start_thread () from /lib/libpthread.so.0
#5  0x00007fa87d1545dd in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fa86a78c950 (LWP 26789)):
#0  0x00007fa87f926fed in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x00007fa87fb97c37 in QWaitCondition::wait () from /usr/lib/libQtCore.so.4
#2  0x00007fa87fb8d819 in ?? () from /usr/lib/libQtCore.so.4
#3  0x00007fa87fb96c62 in ?? () from /usr/lib/libQtCore.so.4
#4  0x00007fa87f922fc7 in start_thread () from /lib/libpthread.so.0
#5  0x00007fa87d1545dd in clone () from /lib/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fa8826c6750 (LWP 26776)):
[KCrash Handler]
#5  0x00007fa872030ce7 in millisecondsToTM (milli=1.0725067677480886e+20, utc=true, t=0x7fff8a710260) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kjs/date_object.cpp:471
#6  0x00007fa8720321c4 in KJS::DateProtoFunc::callAsFunction (this=0x7fa869e70dc0, exec=0x7fff8a710c80, thisObj=0x7fa869e72140, args=@0x7fff8a710bd0)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kjs/date_object.cpp:627
#7  0x00007fa872065179 in KJS::JSObject::call (this=0x16c, exec=0x2069766, thisObj=0x0, args=@0x0) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kjs/object.cpp:69
#8  0x00007fa872080031 in KJS::Machine::runBlock (exec=0x7fff8a710c80, codeBlock=<value optimized out>, parentExec=0x7fff8a711770) at codes.def:1192
#9  0x00007fa8720616fc in KJS::FunctionImp::callAsFunction (this=0x7fa869e7c080, exec=0x7fff8a711770, thisObj=<value optimized out>, args=@0x7fff8a7116c0)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kjs/function.cpp:144
#10 0x00007fa872065179 in KJS::JSObject::call (this=0x16c, exec=0x2069766, thisObj=0x0, args=@0x0) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kjs/object.cpp:69
#11 0x00007fa872080031 in KJS::Machine::runBlock (exec=0x7fff8a711770, codeBlock=<value optimized out>, parentExec=0x7fff8a7122f0) at codes.def:1192
#12 0x00007fa8720616fc in KJS::FunctionImp::callAsFunction (this=0x7fa869e7e0c0, exec=0x7fff8a7122f0, thisObj=<value optimized out>, args=@0x7fff8a7121b0)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kjs/function.cpp:144
#13 0x00007fa872065179 in KJS::JSObject::call (this=0x16c, exec=0x2069766, thisObj=0x0, args=@0x0) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kjs/object.cpp:69
#14 0x00007fa872080031 in KJS::Machine::runBlock (exec=0x7fff8a7122f0, codeBlock=<value optimized out>, parentExec=0x0) at codes.def:1192
#15 0x00007fa872035489 in KJS::FunctionBodyNode::execute (this=0x38425f0, exec=0x7fff8a7122f0) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kjs/nodes.cpp:928
#16 0x00007fa872067fba in KJS::Interpreter::evaluate (this=0x232f910, sourceURL=@0x7fff8a712650, startingLineNumber=0, code=<value optimized out>, codeLength=<value optimized out>, 
    thisV=0x7fa86c480000) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kjs/interpreter.cpp:556
#17 0x00007fa872068083 in KJS::Interpreter::evaluate (this=0x0, sourceURL=@0x0, startingLineNumber=0, code=<value optimized out>, thisV=<value optimized out>)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kjs/interpreter.cpp:496
#18 0x00007fa872718201 in KJS::KJSProxyImpl::evaluate (this=0x23c7690, filename=<value optimized out>, baseLine=0, str=@0x7fff8a712ae0, n=<value optimized out>, completion=0x7fff8a7126e0)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/khtml/ecma/kjs_proxy.cpp:158
#19 0x00007fa8724dbeb1 in KHTMLPart::executeScript (this=0x2590550, filename=@0x7fff8a712830, baseLine=0, n=@0x7fff8a7127f0, script=@0x7fff8a712ae0)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/khtml/khtml_part.cpp:1326
#20 0x00007fa87256c8c8 in khtml::HTMLTokenizer::scriptExecution (this=0x2368cd0, str=@0x7fff8a712ae0, scriptURL=<value optimized out>, baseLine=0)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/khtml/html/htmltokenizer.cpp:501
#21 0x00007fa872570e06 in khtml::HTMLTokenizer::notifyFinished (this=0x2368cd0) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/khtml/html/htmltokenizer.cpp:2123
#22 0x00007fa87269519f in khtml::CachedScript::checkNotify (this=0x36f0c90) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/khtml/misc/loader.cpp:389
#23 0x00007fa872695384 in khtml::CachedScript::data (this=0x36f0c90, buffer=<value optimized out>, eof=<value optimized out>)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/khtml/misc/loader.cpp:381
#24 0x00007fa8726930bd in khtml::Loader::slotFinished (this=0x22f5bf0, job=0x37c0140) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/khtml/misc/loader.cpp:1407
#25 0x00007fa872698fc7 in khtml::Loader::qt_metacall (this=0x22f5bf0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff8a712dd0)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/build/khtml/loader.moc:131
#26 0x00007fa87fc94db2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#27 0x00007fa8802dd6d2 in KJob::result (this=0x16c, _t1=0x37c0140) at /home/miki/work1/kdemod-core42/work/kdelibs/src/build/kdecore/kjob.moc:188
#28 0x00007fa8802dda4f in KJob::emitResult (this=0x37c0140) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kdecore/jobs/kjob.cpp:304
#29 0x00007fa881539a90 in KIO::SimpleJob::slotFinished (this=0x37c0140) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kio/kio/job.cpp:485
#30 0x00007fa88153acb3 in KIO::TransferJob::slotFinished (this=0x37c0140) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kio/kio/job.cpp:962
#31 0x00007fa88153bd35 in KIO::TransferJob::qt_metacall (this=0x37c0140, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff8a7131d0)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/build/kio/jobclasses.moc:343
#32 0x00007fa87fc94db2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#33 0x00007fa8815f7e81 in KIO::SlaveInterface::dispatch (this=0x2470ca0, _cmd=104, rawdata=<value optimized out>)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kio/kio/slaveinterface.cpp:175
#34 0x00007fa8815f49d2 in KIO::SlaveInterface::dispatch (this=0x2470ca0) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kio/kio/slaveinterface.cpp:91
#35 0x00007fa8815e7563 in KIO::Slave::gotInput (this=0x2470ca0) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kio/kio/slave.cpp:322
#36 0x00007fa8815e97c8 in KIO::Slave::qt_metacall (this=0x2470ca0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fff8a7135f0)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/build/kio/slave.moc:76
#37 0x00007fa87fc94db2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#38 0x00007fa881504e71 in KIO::ConnectionPrivate::dequeue (this=0x24caf50) at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kio/kio/connection.cpp:82
#39 0x00007fa8815052ca in KIO::Connection::qt_metacall (this=0x22c3680, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x31923f0)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/build/kio/connection.moc:73
#40 0x00007fa87fc8f408 in QObject::event () from /usr/lib/libQtCore.so.4
#41 0x00007fa87eebb40d in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#42 0x00007fa87eec368a in QApplication::notify () from /usr/lib/libQtGui.so.4
#43 0x00007fa880ae0a8b in KApplication::notify (this=0x7fff8a714220, receiver=0x22c3680, event=0x29cd270)
    at /home/miki/work1/kdemod-core42/work/kdelibs/src/kdelibs-4.2.71/kdeui/kernel/kapplication.cpp:307
#44 0x00007fa87fc7f39c in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#45 0x00007fa87fc8000a in QCoreApplicationPrivate::sendPostedEvents () from /usr/lib/libQtCore.so.4
#46 0x00007fa87fca8d83 in ?? () from /usr/lib/libQtCore.so.4
#47 0x00007fa87b4a201a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#48 0x00007fa87b4a56e0 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#49 0x00007fa87b4a587c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#50 0x00007fa87fca8a0f in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#51 0x00007fa87ef52aff in ?? () from /usr/lib/libQtGui.so.4
#52 0x00007fa87fc7dc42 in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#53 0x00007fa87fc7e00d in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#54 0x00007fa87fc802d4 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#55 0x00007fa8822cbca9 in kdemain (argc=<value optimized out>, argv=<value optimized out>) at /home/miki/work1/kdemod-core42/work/kdebase/src/kdebase-4.2.71/apps/konqueror/src/konqmain.cpp:257
#56 0x00007fa87d0a3546 in __libc_start_main () from /lib/libc.so.6
#57 0x00000000004007c9 in _start ()
Comment 1 A. Spehr 2009-05-03 10:15:09 UTC
Do you know what website you were on? Has it happened before with the same backtrace? (ie The part after [KCrash Handler] will be the same or very similar.)

Thanks!
Comment 2 miki 2009-05-03 10:20:20 UTC
crash every time i open http://espn.go.com/tennis/
Comment 3 Dario Andres 2009-05-03 14:06:20 UTC
The backtrace looks related to bug 187928. However, as stated in that bug, when using 4.3trunk it should only freeze but not crash. (may be it changed on updated trunk+qt4.5.1)
Thanks
Comment 4 A. Spehr 2009-05-04 12:56:47 UTC
I'm using an older qt-copy (4.5.0 + patches), and it segfaults on me.
Comment 5 miki 2009-05-04 13:39:47 UTC
this is qt-copy ..I just rename Qt 4.5.1
Comment 6 Maksim Orlovich 2009-05-05 17:05:36 UTC

*** This bug has been marked as a duplicate of bug 189373 ***