Bug 191417 - "Fade" causes windows to momentarily appear above visible auto-hiding panels
Summary: "Fade" causes windows to momentarily appear above visible auto-hiding panels
Status: RESOLVED DUPLICATE of bug 158262
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-03 06:26 UTC by Stephan Sokolow
Modified: 2009-05-03 10:21 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Sokolow 2009-05-03 06:26:49 UTC
Version:            (using KDE 4.2.2)
Installed from:    Compiled From Sources

When using auto-hiding panels with the "Fade" effect, the panels are forced below the fading window for the duration of the animation. (Defeating one of the purposes of the fade: to provide a more relaxing user experience by removing as many perceptually instantaneous changes as possible)

The simplest way to test this is to put your system tray in an auto-hide panel, move a window with a tray icon so the panel overlaps it when visible, and then click the tray icon to hide the window.

I've tested it with Audacious Media Player 1.5.1 (GTK+), X-Chat 2.8.6 (GTK+ with a differently-implemented tray icon), BasKet Note Pads 1.0.2 (KDE 3.5), and Kopete 4.2.2 (KDE 4.3) to confirm that it's not specific to a given tray icon implementation and I've confirmed that there's no visible suspension of panel-on-top with "Fade" disabled.
Comment 1 Martin Flöser 2009-05-03 10:21:23 UTC

*** This bug has been marked as a duplicate of bug 158262 ***