Bug 191395 - lokalize crash on action randomly
Summary: lokalize crash on action randomly
Status: RESOLVED DUPLICATE of bug 191122
Alias: None
Product: lokalize
Classification: Applications
Component: general (show other bugs)
Version: 0.3
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Nick Shaforostoff
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-02 22:54 UTC by Valdas
Modified: 2009-05-19 16:58 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Crash report (2.41 KB, application/octet-stream)
2009-05-02 22:55 UTC, Valdas
Details
Sample file (66.62 KB, application/octet-stream)
2009-05-02 22:56 UTC, Valdas
Details
Report on crash on Acer Aspire One (kubuntu 9.04 32 bit) (5.02 KB, application/gzip)
2009-05-05 19:53 UTC, Valdas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Valdas 2009-05-02 22:54:33 UTC
Version:           0.3 (using KDE 4.2.2)
OS:                Linux
Installed from:    Ubuntu Packages

 Seems that these crashes related to large file, I attached one.

 When this file (~6500 strings) are loaded, Lokalize crashes at random action: one time it crashes when I pressed "Next untranslated", next time when I pressed PgDown key, or "Ctrl+S", or rearranged "Message Tree" field...
 
 First crash I noticed April 27, I worked with Kubuntu 8.10 i386 (recently updated) and KDE 4.2.2. Then I upgraded to Kubuntu 9.04 (clean install), but crashes remains.
Comment 1 Valdas 2009-05-02 22:55:52 UTC
Created attachment 33302 [details]
Crash report
Comment 2 Valdas 2009-05-02 22:56:36 UTC
Created attachment 33303 [details]
Sample file
Comment 3 Nick Shaforostoff 2009-05-02 23:28:15 UTC
do you have a x86_64 machine?

can you poossibly try other's distro build?
Comment 4 Valdas 2009-05-04 20:21:40 UTC
 Test results:
 I working on Dell Inspiron 1520 notebook (Intel(R) Core(TM)2 Duo CPU T7250  @ 2.00GHz; 2 GB RAM). In this PC (running Kubuntu 9.04 32bit as mentioned above) today I setted VirtualBox (v2.2.2 r46594). In VB I installed two Linux distributions: Kubuntu 9.04 64bit and MadrivaLinuxOne 2009.01 i586. On both virtual machines I tested Lokalize (v 0.3) and got NO crash.
 Maybe I must test it on real 64 bit PC (I have one with amd64 but with WinXP)?
Comment 5 Nick Shaforostoff 2009-05-04 20:44:33 UTC
no. i asked because the first reporter of this bug used 64bit machine.

now i still wonder whether Lokalize would crash on MadrivaLinuxOne 2009.01 i586 if it was installed on real hardware.

also, your news are bad because it seems that i won't be able to reproduce the crash on virtualbox emulating 64bit hardware.
Comment 6 Valdas 2009-05-05 13:46:48 UTC
 I recovered from dust my old PC: VIA motherboard, Celeron CPU at 800MHz, 0.5 GB RAM :)
 In this PC I installed "MadrivaLinuxOne 2009.01 i586" and tested Lokalize v0.3: no crash...
Comment 7 Nick Shaforostoff 2009-05-05 15:04:55 UTC
wow ))

now i dare to ask you to install kubuntu on it ;)
because, if kubuntu won't exhibit crashes on your old hardware, we're still nowhere.
Comment 8 Valdas 2009-05-05 19:50:23 UTC
 I tested Lokalize on my secondary PC Acer Aspire One (Intel Atom CPU N270 at 1.6GHz; 1.5 GB RAM) with Kubuntu 9.04 i386 (recently updated): Lokalize crashes.
 I noticed that crash ending is various: simply disappear, crash dialog fires up but "unable reproduce useful backtrace", crash with SIGSEGV, crash with SIGABRT.
 I attached two crash reports, and console output from secont crash (maybe useful).

 P.S. one comes in mind, maybe this is related to multicore CPU (my first and second PC is dualcore, and maybe in VB virtual machine exists only siglecore CPU so no crash)?

 P.S.S. sorry, I know, my English is bad :)
Comment 9 Valdas 2009-05-05 19:53:40 UTC
Created attachment 33373 [details]
Report on crash on Acer Aspire One (kubuntu 9.04 32 bit)
Comment 10 Nick Shaforostoff 2009-05-05 21:05:06 UTC
not directly, at least: i have dual core cpu too -- Genuine Intel(R) CPU 2160  @ 1.80GHz and run debian+qt4.5. there is no random crashes. i also own Acer Aspire One with openSUSE -- no crashes as well.
Comment 11 Nick Shaforostoff 2009-05-05 21:22:20 UTC
more news: i downloaded ubuntu package from http://packages.ubuntu.com/karmic/lokalize ,  ran it, played with messages list view for few seconds, then started typing and got a crash.

can't reproduce it neither on ubuntu's nor debian's build though.

when you find time, try using debian's build from http://packages.debian.org/sid/lokalize  (open the .deb with mc or any other archiver and extract usr/bin/lokalize binary from it. then run it by typing ./lokalize in the directory where you extracted it)
Comment 12 Valdas 2009-05-05 22:11:53 UTC
I tried that deb (i386): Lokalize crashes...
Comment 13 Valdas 2009-05-06 18:47:22 UTC
 Maybe useful info: I noticed one thing - when I loaded kstars.po in to Lokalize, I noticed high disc load (by hdd led) that continues more than half min, also iotop shows that Lokalize heavy uses hdd. So I started Lokalize from console and loaded kstars.po (it is also large ~1MB): console starts continuously filling with lines like

lokalize(23505) TM::TMView::slotCacheSuggestions: 613

changes (grows) only number at line end. And if I close Lokalize during that disk load, sometime I got report about crash.
Comment 14 Nick Shaforostoff 2009-05-06 20:07:47 UTC
it's because lokalize fetches suggestions for all 6859 entries of kstars. quite a bit of work to do ;)

you can disable it in the settings dialog (try this to see if it is a reason for crashes on your computer).
Comment 15 Pino Toscano 2009-05-18 23:42:12 UTC
This looks like the same problem of bug #191122. Waiting for a better backtrace.
Comment 16 Nick Shaforostoff 2009-05-19 16:58:07 UTC

*** This bug has been marked as a duplicate of bug 191122 ***