Bug 191048 - Lokalize crashes during translation
Summary: Lokalize crashes during translation
Status: RESOLVED DUPLICATE of bug 191122
Alias: None
Product: lokalize
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Nick Shaforostoff
URL:
Keywords:
: 191612 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-29 17:10 UTC by jonathan aquilina
Modified: 2009-05-19 16:56 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jonathan aquilina 2009-04-29 17:10:54 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    I Don't Know

lokalize:
   installierte Version: 4:4.2.1-0ubuntu1~intrepid1
Lokalize crashed during a translation session. (90%finished)
Anwendung: Lokalize (lokalize), Signal SIGABRT
 [Current thread is 0 (LWP 4659)]
Thread 2 (Thread 0xb4410b90 (LWP 4660)):
 #0 0xb7f0c430 in __kernel_vsyscall ()
 #1 0xb65ccf13 in ?? () from /lib/tls/i686/cmov/libc.so.6
 #2 0xb6551cbd in ?? () from /lib/tls/i686/cmov/libc.so.6
 Backtrace stopped: previous frame identical to this frame (corrupt stack?)
Thread 1 (Thread 0xb5e4d6c0 (LWP 4659)):
 [KCrash Handler]
 #6 0xb7f0c430 in __kernel_vsyscall ()
 #7 0xb65088a0 in raise () from /lib/tls/i686/cmov/libc.so.6
 #8 0xb650a268 in abort () from /lib/tls/i686/cmov/libc.so.6
 #9 0xb654616d in ?? () from /lib/tls/i686/cmov/libc.so.6
 #10 0xb654c454 in ?? () from /lib/tls/i686/cmov/libc.so.6
 #11 0xb654f4b6 in ?? () from /lib/tls/i686/cmov/libc.so.6
 #12 0xb65508c5 in malloc () from /lib/tls/i686/cmov/libc.so.6
 #13 0xb67aef5d in qMalloc () from /usr/lib/libQtCore.so.4
 #14 0xb67f6567 in QString::QString () from /usr/lib/libQtCore.so.4
 #15 0xb67f6a1e in QString::left () from /usr/lib/libQtCore.so.4
 #16 0xb6ba0665 in KuitSemanticsPrivate::formatFromContextMarker (ctxmark_=@0xbf809ad0, text=@0xbf809acc) at /build/buildd/kde4libs-4.2.1a/kdecore/localization/kuitsemantics.cpp:1046
 #17 0xb6ba4f76 in KuitSemanticsPrivate::format (this=0x9c9db90, text=@0xbf809acc, ctxt=@0xbf809ad0) at /build/buildd/kde4libs-4.2.1a/kdecore/localization/kuitsemantics.cpp:975
 #18 0xb6ba50f9 in KuitSemantics::format (this=0x9c87e70, text=@0xbf809acc, ctxt=@0xbf809ad0) at /build/buildd/kde4libs-4.2.1a/kdecore/localization/kuitsemantics.cpp:1689
 #19 0xb6b75609 in KLocalizedStringPrivate::postFormat (this=0xa312788, text=@0xbf809ad4, lang=@0xbf809b20, lscr=@0xbf809b18, ctxt=@0xbf809ad0)
     at /build/buildd/kde4libs-4.2.1a/kdecore/localization/klocalizedstring.cpp:477
 #20 0xb6b77edf in KLocalizedStringPrivate::toString (this=0xa312788, locale=0x9c8bae8) at /build/buildd/kde4libs-4.2.1a/kdecore/localization/klocalizedstring.cpp:296
 #21 0xb6b78894 in KLocalizedString::toString (this=0xbf809b94) at /build/buildd/kde4libs-4.2.1a/kdecore/localization/klocalizedstring.cpp:205
 #22 0x080874dd in _start ()

This bug can be found at https://bugs.launchpad.net/ubuntu/+source/kde4libs/+bug/351038
Comment 1 Nick Shaforostoff 2009-05-04 22:12:11 UTC
*** Bug 191612 has been marked as a duplicate of this bug. ***
Comment 2 Pino Toscano 2009-05-18 23:43:28 UTC
This looks like the same problem of bug #191122. Waiting for a better backtrace.
Comment 3 Nick Shaforostoff 2009-05-19 16:56:40 UTC

*** This bug has been marked as a duplicate of bug 191122 ***