Bug 190667 - Amarok 2 - Smart Playlists
Summary: Amarok 2 - Smart Playlists
Status: RESOLVED INTENTIONAL
Alias: None
Product: amarok
Classification: Unclassified
Component: Playlists/Dynamic Playlists (show other bugs)
Version: 2.1-SVN
Platform: Ubuntu Packages Linux
: NOR wishlist with 155 votes (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
: 190812 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-25 23:18 UTC by Chris Brown
Modified: 2010-04-26 02:11 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.3.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Brown 2009-04-25 23:18:31 UTC
Version:           2.0.2 (using KDE 4.2.2)
OS:                Linux
Installed from:    Ubuntu Packages

Would love to see smart playlists reimplemented in Amarok 2.

For example currently there is no way to play:

-A selection of your favourite tracks (ie. rating > 4.5)
-A selection of new tracks (ie. playcount = 0)

The examples above could also be addressed by modifying the advanced search capabilities of the collection browser so that you could search based on rating and playcount. Currently those attributes are not available to be searched. In my mind this seems the more sensible solution.
Comment 1 Seb Ruiz 2009-04-27 14:05:29 UTC
*** Bug 190812 has been marked as a duplicate of this bug. ***
Comment 2 Unknown 2009-04-27 14:12:30 UTC
Sorry for the duplicate, I didn't know "Intelligent Playlist" and "Smart Playlist" were the same thing.
So, I'd like to see this back, too :)
Comment 3 Andreas Stangl 2009-05-05 12:46:38 UTC
Please bring 'em back, I really liked the smart playlist editor in amaork1, currently (I use amarok 2.0.2 on gentoo) one is not able to specify things like "greater" (i.e. rating greater than 4), "less", etc. only "equal" is available. Even though the dynamic playlist does almost generate the same track listing as my good old smart playlist did, but there are plenty of tracks appearing in my playlist that I would like to sort out, currently I don't know how because I can only specify criteria with "equal". It would also be nice to couple different criterias via "AND" and/or "OR". Is there a plan to brink back "smart playlists" at all?
Comment 4 Ralf Jung 2009-07-28 21:39:53 UTC
I can second that feature request - it's one of the features useful for organizing collections which I am missing.
Comment 5 Rolando 2009-08-18 08:00:55 UTC
I too would love to see this feature again. It's the only thing from 1.4 that I actually miss.
Comment 6 Myriam Schweingruber 2009-08-18 11:21:56 UTC
(In reply to comment #5)
> I too would love to see this feature again. It's the only thing from 1.4 that I
> actually miss.

Why did you remove Ralf from this report? To subscribe yourself just tick the field below this space...
Comment 7 Matthew Flaschen 2009-09-02 03:29:37 UTC
As an example of another technique the old Smart Playlists enabled but (apparently) is no longer available, I used to have a smart playlist called "Old Favorites".  It would select tracks that had above a certain score, and had been last played more than x days ago.  This is a good way to hear music you like and aren't bored with.

So far as I can tell, this type of matching is not possible (yet!) in Amarok 2.
Comment 8 Christian Engels 2009-09-07 16:50:43 UTC
Additionally i want to mention, that any kind of sorting, for example by filepath, is not possible with Dynamic Playlists at the Moment.
Comment 9 Mathias Homann 2009-09-25 09:47:08 UTC
re #7 the "last played" filter that exists in current (2.1.85) amarok2 is actually not useful at all.

I can define a filter "last played before ..." with a FIXED DATE.

Given a collection that is not very big, that filter would start to come up empty after some time...

Where did the old "last played X days ago" filter go??? That was actually dead useful...

my playlist in amarok 1 was "score > 75 and last played 7 days ago"...
Comment 10 vmos 2009-09-26 12:05:29 UTC
yes please, I would particularly like the ability to select file recently added to the collection
Comment 11 Richard Homonnai 2009-11-29 02:40:45 UTC
I really would like this to return too :)
Comment 12 JoeD 2009-12-16 09:01:03 UTC
Most important feature wich keeps me from using Amarok2.

Very sad about it.

My Music Collection is way to big to rather manage Playlists in a other way then this.
Comment 13 Rolando 2009-12-16 10:37:51 UTC
For me, amarok 2.2.1 already has most of the features that I missed from the smart playlists of 1.4. The much improved collection search now allows creating more advanced filters, thus allowing me to see all the tracks in my collection matching a certain criteria (like rating:>3 or playcount=0). 

Also, the ability to limit the number of upcoming tracks in a dynamic playlist lets me create a playlist matching a certain criteria of only a certain length - I simply set my criteria, click on repopulate once, and then disable the dynamic playlist.

The only thing that I think is still missing is a way to view tracks added to the collection in the past x days or months. Also the options to choose from when setting a proportional bias in a dynamic playlist are still limited to 'greater than', 'less than', and 'equal to', which doesn't make sense for attributes like "First played" and "Last played". Now I can't limit the tracks to those played in the last x days or within a certain time period - I am forced to choose only one fixed date.

Just these little wrinkles to be ironed out, and pretty much all the features of the 1.4 smart playlists will be available, albeit in slightly different forms.
Comment 14 cyrus_xiii 2010-02-19 20:00:05 UTC
Since labels are back as of 2.2.2, I'm really hoping that future versions of Amarok will take full advantage of them, e.g. allow the creation of playlists that include and exclude tracks based on their labels (among other criteria).

While this would make dynamic playlists much more versatile in general, one distinct use case comes to mind: The ability to turn Amarok into an always-on jukebox which ignores audio books, orchestral scores, superfluous bonus tracks, etc.. Given a large enough collection, the current bias system alone does not cut it for this scenario.
Comment 15 doc.evans 2010-02-19 22:18:19 UTC
I would be happy just to get the functionality back that was described in the OP. That was exactly the way I too used smart playlists in 1.4. As a result of this lack, I'm back to using 1.4. I tried 2.x for quite some time (months), but eventually the inability use it the way I wanted sent me back to 1.4
Comment 16 Soren Harward 2010-04-26 02:11:46 UTC
The new Automated Playlist Generator (APG) brings back the functionality that was present in the Smart Playlists in 1.4.  If there's still anything that Smart Playlists can do that the APG cannot, file a bug report or send me an email, and I'll almost certainly be able to fix it.