Bug 190485 - GUI rendering bugs with Qt 4.5.1
Summary: GUI rendering bugs with Qt 4.5.1
Status: RESOLVED UPSTREAM
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.1-SVN
Platform: unspecified Linux
: HI normal (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-24 01:49 UTC by Mathias Panzenböck
Modified: 2009-04-24 15:16 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
bugs in the look of amaroks gui (48.88 KB, image/png)
2009-04-24 01:50 UTC, Mathias Panzenböck
Details
bugs in the look of amaroks gui with red markings (55.00 KB, image/png)
2009-04-24 01:51 UTC, Mathias Panzenböck
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mathias Panzenböck 2009-04-24 01:49:53 UTC
Version:           2.1-SVN (using 4.2.2 (KDE 4.2.2), 4.2.2-8.fc10 Fedora)
Compiler:          gcc
OS:                Linux (x86_64) release 2.6.27.21-170.2.56.fc10.x86_64

The current SVN version (revision 958392) of amarok shows some GUI bugs. There is no functional problem, only some things that *look* broken. I'll attach a screenshot to show you what I mean. (And a second one with red markings.)
Comment 1 Mathias Panzenböck 2009-04-24 01:50:35 UTC
Created attachment 33046 [details]
bugs in the look of amaroks gui
Comment 2 Mathias Panzenböck 2009-04-24 01:51:01 UTC
Created attachment 33047 [details]
bugs in the look of amaroks gui with red markings
Comment 3 Mathias Panzenböck 2009-04-24 01:53:23 UTC
Oh, I use: Fedora 10, KDE 4.2.2, Qt 4.5.1, nvidia official drivers 180.44
Comment 4 Seb Ruiz 2009-04-24 02:13:33 UTC
This is certainly not an Amarok bug, but I'm wondering if Qt 4.5.1 is responsible (unlikely i think).

My guess is that it's a system config problem.
Comment 5 Mathias Panzenböck 2009-04-24 02:22:01 UTC
What configuration could be the problem? I didn't change any configuration. Amarok started to look like that after svn up. I think the Qt update from 4.5.0 to 4.5.1 happened at the same time, but I'm not sure about this.
Comment 6 Mark Kretschmann 2009-04-24 09:00:12 UTC
Confirming based on reports from other users. Seems to be a Qt 4.5.1 thing.

Question is how we can work around it :)
Comment 7 Mark Kretschmann 2009-04-24 09:06:10 UTC
A KDE developer just said this:

09:00 < nixternal> markey: seems they are using KDE 4.2.2 with Qt 4.5.1, which I thought was a no-no

09:01 < nixternal> they should be seeing it in more than just Amarok...I haven't had it in Amarok yet, but I did in Kate, Konqueror, and...can't remember the other


So this creates two new questions: 

1) Does this happen with KDE trunk as well? You're not meant to use Qt 4.5.1 with KDE 4.2.2.

2) Does it happen in other KDE applications as well?
Comment 8 Mark Kretschmann 2009-04-24 10:28:43 UTC
Just found this blog about Qt 4.5.1 with KDE 4.2.2 problems - we're definitely not the only application affected by it:


http://rdieter.livejournal.com/13559.html
Comment 9 Eelko Berkenpies 2009-04-24 12:56:11 UTC
Could this be related to bug #184714 ? Qt 4.5.1 is supposed to be forward- and backward compatible so maybe it's something that never got resolved in the first place?

Just to be clear, I'm not trying to make a point here. I'm just thinking out loud. :)
Comment 10 Mark Kretschmann 2009-04-24 14:37:24 UTC
Well, we just had a guy from QtSoftware in our #amarok IRC channel. Apparently he looked at the issue, and when he was finished, he said this:

12:47 < darktears> markey: i got it, fixed


Unfortunately he left directly after saying that. So I don't know if he meant "fixed it in Qt", or "fixed it in Amarok" :)


At any rate, we haven't received a patch yet. If you see the guy on IRC, please ask him what he meant. His hostmask was darktears [n=darktear@kde/developer/menard].
Comment 11 Than Ngo 2009-04-24 14:43:57 UTC
it's a svg rendering regression in qt-4.5.1 and is fixed in qt-copied
Comment 12 Ingmar Vanhassel 2009-04-24 14:45:39 UTC
(In reply to comment #10)
> Unfortunately he left directly after saying that. So I don't know if he meant
> "fixed it in Qt", or "fixed it in Amarok" :)

The former, see below

> At any rate, we haven't received a patch yet. If you see the guy on IRC, please
> ask him what he meant. His hostmask was darktears
> [n=darktear@kde/developer/menard].

http://websvn.kde.org:80/trunk/qt-copy/patches/0279-svg-rendering-regression.diff?view=log
Comment 13 Mark Kretschmann 2009-04-24 15:03:20 UTC
Thanks for clearing this up :)

Closing the report then. 4.5.1 users should downgrade, or wait for 4.5.2, or use qt-copy from KDE SVN.