Bug 190400 - Ark should launch an external viewer to preview file contents
Summary: Ark should launch an external viewer to preview file contents
Status: RESOLVED DUPLICATE of bug 179066
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: 2.12
Platform: unspecified Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Harald Hvaal
URL:
Keywords:
: 109422 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-23 03:58 UTC by Claus Wilke
Modified: 2009-08-02 02:57 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Claus Wilke 2009-04-23 03:58:24 UTC
Version:           2.12 (using 4.2.2 (KDE 4.2.2) "release 111", KDE:KDE4:Factory:Desktop / openSUSE_11.1)
Compiler:          gcc
OS:                Linux (i686) release 2.6.27.19-3.2-default

I don't understand the philosophy behind using a blocking dialog to preview files in an archive. Using a non-blocking dialog, or better, launching an external viewer, would be so much more useful.

Use case:
I download a zip file containing 5 pdf files. I would like to look at them and print them, but have no need to save them on my local disk. If ark opened them in okular, I could do all I need to do by just clicking on the files. Instead, in the current setting, I have to extract the files first, and then open them from dolphin. At that point, it's so much more work that I'm faster doing everything from command line instead of using ark.

I also cannot look at two files side by side in the current setup.
Comment 1 Raphael Kubo da Costa 2009-04-23 04:12:32 UTC
Now that you mention it, I cannot disagree with your point. I don't know if this can be done for 4.3 since we're in soft freeze.

I'd like to listen to Harald's opinion on this too.
Comment 2 Harald Hvaal 2009-04-23 10:32:49 UTC
For this to be done, we would need to set the preview dialog to non-modal, and use signals/slots for deleting the temp file when finished.  Other than this, it should not be necessary with any new messages or such, I believe.
So I believe it's an easy-to-implement small feature, but like raphael said, we're in a soft freeze and already have many other things that need to be focused on first.
Comment 3 Raphael Kubo da Costa 2009-05-10 06:50:27 UTC
*** Bug 109422 has been marked as a duplicate of this bug. ***
Comment 4 Sergio PR 2009-05-18 13:14:07 UTC
I think that would be great :)
Comment 5 anton 2009-06-26 22:43:30 UTC
I just wanted to report exactly the same wish and glad to see that I'm not the only one who see this.

There are even more issues I have with ark's internal editor:

1. ctrl+c does not work for html files opened in internal viewer
2. there is no context menu for basic operations (ctrl+c) in text viewers
3. if I open xml file, it is opened in html rendering mode (so I can't see tags) and I can't switch to tag viewing mode.
4. gwenview could be much better for viewing pictures.
etc


opening external application for viewing files would solve all those and many other issues and there would be no need to support internal viewer which would always be less functional than specialized applications.

Also the items in ark should all have standard kde context menu (open/open with/user actions/properties etc) - "open with" is most wanted from this list, so one can choose any external program to open file in.

From this point of view for me krusader is ideal archiver with all listed features available (thank's to "krarc:" kio as far as I can understand), but in many cases opening archive in ark is more quick and convenient - I wish it could have all those features either.
Comment 6 Raphael Kubo da Costa 2009-08-01 20:54:37 UTC
Actually, the features requested here (aside from making the previewer non-modal) are the same ones listed in bug 179066, so I'm marking this bug as a duplicate of it.

*** This bug has been marked as a duplicate of bug 179066 ***