Bug 190334 - Incorrect rendering of a consonant conjunct while writing Bengali in KDE applications
Summary: Incorrect rendering of a consonant conjunct while writing Bengali in KDE appl...
Status: RESOLVED UPSTREAM
Alias: None
Product: kate
Classification: Unclassified
Component: part (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-22 12:41 UTC by Runa Bhattacharjee
Modified: 2011-08-09 10:29 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Runa Bhattacharjee 2009-04-22 12:41:37 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    Fedora RPMs

While typing in Bengali within various KDE applications like kwrite, kate, konqueror etc. the following consonant conjunct is not being rendered correctly:

র+ZWJ+্+য

The corresponding unicode values for the above are:

U09B0+U200D+U09CD+U09AF

Steps to Reproduce:

1. Open kwrite
2. Enter the above consonant conjuct combination using a Bengali keyboard or Unicode RAWCODE 

Expected Behaviour:

The consonant should be rendered correctly.

Screenshot of incorrect rendering:
 
http://runab.fedorapeople.org/assorted-bugs/incorrect-ra.png

Screenshot of the correct rendering: 

http://runab.fedorapeople.org/assorted-bugs/correct-ra.png
Comment 1 Kevin Kofler 2009-04-22 14:08:03 UTC
Confirming as the report looks clearly valid.
Comment 2 Kevin Kofler 2009-04-22 14:08:39 UTC
Looks like a KatePart, or possibly Qt bug.
Comment 3 Anne-Marie Mahfouf 2009-04-24 14:30:32 UTC
The correct consonant should be
র‍্য
while QTextEdit renders it as
র‍ ্য
Comment 4 Runa Bhattacharjee 2009-10-30 08:13:16 UTC
Hello,
Are there any recent updates about this issue? Thanks.
Comment 5 Anne-Marie Mahfouf 2009-11-03 13:24:43 UTC
Runa, is there a Qt bug report for it?
Comment 6 Runa Bhattacharjee 2009-11-04 06:47:03 UTC
(In reply to comment #5)
> Runa, is there a Qt bug report for it?

Anne, I did not file any Qt bug and am not aware of any being filed for this issue. Kevin mentions that it could be a 'KatePart, or possibly Qt bug', so I am not sure what to do next.

Thanks
Comment 7 Anne-Marie Mahfouf 2009-11-04 14:45:11 UTC
QTextEdit does not render it properly. Please try the following
------------
#include <QApplication>
#include <QTextEdit>

int main( int argc, char ** argv )
{

    QApplication a( argc, argv );
    QWidget window;
    window.resize(400, 250);
    QTextEdit *textWidget1 = new QTextEdit;
    textWidget1->show();

    return a.exec();
}
-------
qmake -project
qmake
make

run the program
and paste র‍্য in it
it renders as র ্ য

you can report that to Qt tracker probably
Comment 8 Anne-Marie Mahfouf 2009-11-04 14:52:46 UTC
Of course use Firefox (not Konqueror) to display this page and see my latest comment, all KDE component do not display the consonant properly and then it makes no sense. KMail either does not display it.
GEdit works well by the way.
Comment 9 Kevin Kofler 2009-11-04 16:07:53 UTC
So all evidence points to a Qt bug, we need to report this to the Qt folks at Nokia.
Comment 10 Kevin Kofler 2009-11-04 16:10:37 UTC
For reference, a crude ASCII art approximation of the correct rendering:
____
.<|S

Anything with dotted circles in it is an incorrect rendering.
Comment 11 Runa Bhattacharjee 2010-09-14 10:13:16 UTC
http://bugreports.qt.nokia.com/browse/QTBUG-13616
Comment 12 Dominik Haumann 2011-08-09 10:29:14 UTC
It seems some kind of patch was finally merged. Maybe for Qt4.8, I don't really know. You will find more information here (especially in the 2nd link):
https://bugreports.qt.nokia.com//browse/QTBUG-13616
http://qt.gitorious.org/qt/qt/merge_requests/2484

I resolve this as upstream, as it's not a Kate issue. It's all in the Qt hands.