Bug 190071 - [testcase] HTML file does not print correctly
Summary: [testcase] HTML file does not print correctly
Status: RESOLVED FIXED
Alias: None
Product: konqueror
Classification: Unclassified
Component: khtml printing (show other bugs)
Version: SVN
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords: testcase
Depends on:
Blocks:
 
Reported: 2009-04-19 14:45 UTC by Michael Leupold
Modified: 2011-03-28 16:55 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
testcase (34.72 KB, text/html)
2009-04-19 14:46 UTC, Michael Leupold
Details
testcase (54.60 KB, application/octet-stream)
2009-04-19 14:47 UTC, Michael Leupold
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Leupold 2009-04-19 14:45:30 UTC
Version:            (using Devel)
OS:                Linux
Installed from:    Compiled sources

Printing the attached file does not print nicely in Konqueror trunk r955492. Printing it using FireFox works as expected.
Comment 1 Michael Leupold 2009-04-19 14:46:39 UTC
Created attachment 32927 [details]
testcase

This is the file that doesn't print correctly.
Comment 2 Michael Leupold 2009-04-19 14:47:34 UTC
Created attachment 32928 [details]
testcase

This is what printing to pdf looks like. Printing to ps bears the same results.
Comment 3 Matthew Dawson 2009-06-21 01:48:27 UTC
Still reproducible with SVN snapshot r984032.
Comment 4 Samuel Brack 2011-01-07 15:49:12 UTC
Still not fixed in 4.5.4
Comment 5 Allan Sandfeld 2011-03-28 16:53:59 UTC
Git commit 3d44cb1fa7a4cc935813f4bcacc132d3bace54d7 by Allan Sandfeld Jensen.
Committed on 28/03/2011 at 16:38.
Pushed by carewolf into branch 'KDE/4.6'.

Fix serious regression in table printing

Old behavior restored after RenderRow has gotten their own coordinates.
BUG:259163
BUG:190071

M  +13   -20   khtml/rendering/render_table.cpp     

http://commits.kde.org/kdelibs/3d44cb1fa7a4cc935813f4bcacc132d3bace54d7
Comment 6 Allan Sandfeld 2011-03-28 16:55:35 UTC
Git commit 3075d7bb19cdf5f3e546c3919e38e01482430182 by Allan Sandfeld Jensen.
Committed on 28/03/2011 at 16:38.
Pushed by carewolf into branch 'master'.

Fix serious regression in table printing

Old behavior restored after RenderRow has gotten their own coordinates.
BUG:259163
BUG:190071

M  +13   -20   khtml/rendering/render_table.cpp     

http://commits.kde.org/kdelibs/3075d7bb19cdf5f3e546c3919e38e01482430182