Bug 189995 - add the ability to set the percentage of volume that will me changed
Summary: add the ability to set the percentage of volume that will me changed
Status: CLOSED FIXED
Alias: None
Product: kmix
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
: 48142 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-18 21:07 UTC by stompdagger1
Modified: 2016-09-07 14:19 UTC (History)
13 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description stompdagger1 2009-04-18 21:07:04 UTC
Version:           4.2.2 (using KDE 4.2.2)
OS:                Linux
Installed from:    Gentoo Packages

the current level is 4%, that is too much, it would be great if there will be a feature that enables one to set that level of change
Comment 1 Alexey Shildyakov 2010-08-31 09:58:03 UTC
Duplicate of bug 48142
Comment 2 Christian Esken 2011-08-09 21:26:38 UTC
I have implemented it, but will not put it in the GUI. If you want to change it, please quit KMix, and edit the kmixrc configuration file. In the [Global] section. add VolumePercentageStep , e.g:

[Global]
VolumePercentageStep=2.5

This means 2.5%

This goes live with KDE4.8.
Comment 3 Christian Esken 2011-08-09 21:31:07 UTC
SVN commit 1246058 by esken:

FEATURE: 189995
Percentage of a volume change (MouseWheel, DBUS) can be configured in kmixrc (e.g.  VolumePercentageStep=2.5)

 M  +9 -0      apps/kmix.cpp  
 M  +5 -4      core/mixer.cpp  
 M  +1 -0      core/mixer.h  
 M  +1 -1      gui/kmixdockwidget.cpp  
 M  +2 -1      gui/ksmallslider.cpp  
 M  +2 -2      gui/mdwslider.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1246058
Comment 4 Alexey Shildyakov 2011-08-10 01:55:47 UTC
Does this bug duplicate bug 48142? Christian, could you set bug 48142 as dup of this bug?
Comment 5 Christian Esken 2011-08-10 20:29:27 UTC
Yes, #48142 is a dup. Thanks for the hint, Alexey.
Comment 6 Christian Esken 2011-08-10 20:30:40 UTC
*** Bug 48142 has been marked as a duplicate of this bug. ***
Comment 7 Makowal 2013-02-24 20:10:18 UTC
I would propose to add volume step in kmix configuration. On my laptop default step was 25%, which is clearly too much, and when i set "VolumePercentageStep=1" the step is 3% (it's good for me).
Comment 8 Brallan Aguilar 2013-03-07 03:12:00 UTC
It would be a good improvement :)
Comment 9 Daniel Eckl 2013-03-19 09:14:02 UTC
Seems not to work (anymore?) in Kmix 4.3 running on KDE 4.10.1 (ubuntu 12.10 packages)

Setting is ignored and step size is always 15%.
Comment 10 Andrew 2013-04-23 12:06:25 UTC
Seems broken for me too. VolumePercentageStep set to 4, actual step is 12% (using a mouse wheel on the kmix icon).
KDE 4.10.2 from Fedora 18 x64.
Comment 11 Carl Troein 2013-05-08 12:34:11 UTC
Same thing here on openSuse 12.3 with KMix 4.3 / KDE 4.10.2, except I'm getting 10% changes.
Side note: The default probably ought to be something like 2%, because with 10% there's just one step between normal and painfully loud (or very quiet), at least with my hardware.
Comment 12 okaresz 2013-07-17 12:32:59 UTC
Confirmed, the VolumePercentageStep option works only for global keyboard shortcuts, not the mouse wheel action on applet hover.
Kmix 4.3, KDE 4.10.4
Comment 13 lahirdenganselamat 2013-08-26 00:54:07 UTC
I think the VolumePercentageStep is related with mouse scroll lines on system settings. So if scroll lines is set by 3 lines, and VolumePercentageStep set by 5, we get 3*5=15%. And because I don't know how to quit kmix, I do a reboot to make the settings works. 
I'm using Linuxmint 15 KDE 4.10.5
Comment 14 apache 2013-09-19 15:09:20 UTC
Doesn't work for KDE 4.8.5 (Kubuntu 12.04)
Discussion
http://forum.kde.org/viewtopic.php?f=19&t=92925&p=292671#p292671
Comment 15 Christian Esken 2013-09-25 23:16:56 UTC
I fixed a KMix's internal handling. There seems to be another issue outside of KMix. Please follow its progress in bug 316546. Thus I will keep this ticket closed.
Comment 16 apache 2015-08-18 12:57:48 UTC
Can you please add this option to kmix GUI in Plasma 5, please?