Bug 189904 - konqueror does not work wit slashdot.org web site
Summary: konqueror does not work wit slashdot.org web site
Status: RESOLVED UPSTREAM
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 4.2.2
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 203375 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-17 19:29 UTC by vatbier
Modified: 2010-02-12 05:21 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vatbier 2009-04-17 19:29:26 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    SuSE RPMs

KDE-Four-Live OS: openSUSE 11.1 based Live-CD 
 with latest updates in a virtual machine in Virtualbox
KDE 4.2.2

Go with konqueror to the website http://slashdot.org .
At the bottom of the web page the buttons "Yesterday", "Wednesday", "Tuesday", "Many more" do not work with konqueror.

In Firefox 3.0.8 the slashdot site does work.
Comment 1 Artem S. Tashkinov 2009-05-06 17:18:31 UTC
New slashdot SUCKS and I cannot switch back to index.pl!

However this bug is VALID and in a current state you cannot read slashdot website beyond the first page.
Comment 2 Éric Brunet 2009-05-11 21:55:00 UTC
I see it too. When clicking on the "Yesterday" button, konqueror loads a blank page with the words "Loading New Items"

fully uptodate fedora 10, kde 4.2.2
Comment 3 nucleo 2009-05-13 22:18:20 UTC
I see it too in KDE 4.3 Beta 1 OpenSuse LiveCD.
Comment 4 Éric Brunet 2009-07-30 12:16:26 UTC
Still there in kde 4.2.4, fedora 11.

4 different people see this, shouldn't this bug me marked as confirmed ?
Comment 5 Artem S. Tashkinov 2009-07-30 12:32:40 UTC
(In reply to comment #4)
> Still there in kde 4.2.4, fedora 11.
> 
> 4 different people see this, shouldn't this bug me marked as confirmed ?

It's OK, KDE developers use Firefox. Konqueror is just a by-product which doesn't get enough attention (considering the number of [really annoying] opened bugs against it).
Comment 6 Maksim Orlovich 2009-07-30 15:51:44 UTC
This will be resolved when jQuery 1.3.3 is released and is upgraded to by Slashdot.
Comment 7 Éric Brunet 2009-07-30 16:29:33 UTC
Come on, that's not serious.

* slashdot works with every other browser available
* it even works with older versions of konqueror (3.5.x), so the bug
  with 4.2.x is a regression
* there is no reason to believe that the slashdot site will ever be corrected,
  as it works with the other browsers

Does the KDE developper team officially discourage the use of konqueror ?
Comment 8 Maksim Orlovich 2009-07-30 17:41:51 UTC
(sigh)
- Slashdot uses a certain jQuery function to process html.
- That jQuery function uses a rather inefficient regular expression for that functionality, which will be fixed in the next version
- The pcre library which we use for regular expressions runs out of resources when trying to process the inefficient regular expression (one can see this by increasing your system stack size via ulimit, and bumping the safety threshold in KJS appropriately --- things begin to work) 

Hence, this is unfixable on KDE end short of putting in a horrible regexp rewrite hack, as the two ends involved in the problem (the regular expression and PCRE library) are not in our hands. Luckily, the jQuery dude is very nice, and adjusted the regular expression for the next version (which also can make it anywhere from twice as fast to 30x as fast on other browsers).
Comment 9 Artem S. Tashkinov 2009-07-31 05:41:18 UTC
(In reply to comment #7)
> Come on, that's not serious.
> 
> Does the KDE developper team officially discourage the use of konqueror ?

Probably you are right: see bug 190625 comment 18. ;) And it's not the only comment like this.

In reality and jokes aside, it seems like KDE just doesn't have enough man power (more likely) or developers have their own vision of KDE future (less likely).
Comment 10 Éric Brunet 2009-07-31 14:57:20 UTC
Maksim,

Thank you for your explanations. I am looking forward to seeing slashdot working again.

However, even if I am sure that the slashdot geeks will update real fast to the new jquery library, I am concerned that other websites might still use the older version for many years. Let's face it, there are many websites on which konqueror has some problem, and not all of them are reported here (see footnote). Maybe some of them are also due to jquery 1.3.2 and will never be updated (when it works in firefox, don't fix it). Shouldn't konqueror (or, more probably, pcre) be made to survive the inneficient regexp made by a released version of jquery ?

footnote: I usually only report problems on high profile websites such as slashdot. Would it help if I reported problem on any odd website which happens to work in firefox but not in konqueror ?
Comment 11 Artem S. Tashkinov 2009-08-05 15:29:32 UTC
(In reply to comment #7)
> 
> Does the KDE developper team officially discourage the use of konqueror ?

BTW, Aaron Seigo uses Firefox almost exclusively. :)
Comment 12 Tommi Tervo 2009-08-12 08:49:16 UTC
*** Bug 203375 has been marked as a duplicate of this bug. ***
Comment 13 Éric Brunet 2009-10-12 22:46:02 UTC
By the way, I had the opportunity of running a kde 3.5.2 on a computer running fedora core 4, and the slashdot website was working perfectly. It looks to me that this famous pcre library is not doing its job well, as firefox, internet explorer and old konqueror are able to work with slashdot.

I do hate regressions, and this is certainly one regression.

And once slashdot is fixed upstream, how many other less famous sites won't be working or will be horribly slow because of this bug and the less than optimal pcre ?
Comment 14 Chris Espy 2010-02-04 14:16:00 UTC
I'm still getting this bug. I can't get past the first page of slashdot.
Comment 15 Tommi Tervo 2010-02-04 16:05:03 UTC
There is now workaround available, see bug #191736
I can confirm that it'll fix slashdot too.
Comment 16 Germain Garand 2010-02-12 05:21:10 UTC
SVN commit 1088985 by ggarand:

rewrite a very common and extremely inefficient regular expression pattern
in a form that is equivalent but does not require a recursion.

this is several order of magnitude faster in any RE engine and prevents
libpcre from eating the stack.

BUG: 191736
CCBUG: 189904

 M  +78 -14    regexp.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1088985