Bug 189903 - Allow default Target Album for Image Download
Summary: Allow default Target Album for Image Download
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-Albums (show other bugs)
Version: 2.1.0
Platform: Ubuntu Packages Linux
: NOR wishlist with 30 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
: 160298 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-17 19:15 UTC by Paul Waldo
Modified: 2017-08-16 09:33 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Waldo 2009-04-17 19:15:14 UTC
Version:           0.10.0 (using KDE 4.2.2)
OS:                Linux
Installed from:    Ubuntu Packages

When I download images, I have Digikam set up so that it creates a date-based folder off one of the albums.  My Destination album is always the same, but I must tell Digikam this every time.  It would be nice to be able to tell Digikam in its Setup where the default target location is.  

In the Camera Client window, you could have a section that tells you where this location is, along with a check box to override.  For example, 
"[checkbox here]Download images to /My Albums/camera".  
If the checkbox is selected, Digikam just starts downloading, without asking for a target.  If unchecked, you would get the current behavior of asking for a target.

Thanks for your consideration!
Comment 1 caulier.gilles 2009-04-17 19:28:32 UTC
I'm agree with this concept.

Gilles Caulier
Comment 2 Andi Clemens 2009-04-17 20:31:47 UTC
+1
Comment 3 Leslie Harlley Watter 2009-04-18 03:44:45 UTC
+1
Comment 4 caulier.gilles 2009-05-13 10:02:37 UTC
*** Bug 160298 has been marked as a duplicate of this bug. ***
Comment 5 caulier.gilles 2011-08-10 11:37:14 UTC
Git commit 891a9603e0f547d427375a98798343f276b98fa4 by Gilles Caulier.
Committed on 10/08/2011 at 13:24.
Pushed by cgilles into branch 'master'.

digiKam Camera Interface: to speed-up downloading from camera device, a new settings
have been implemented to configure a default target album for downloading from camera.
If this option is turned off, digiKam will ask where you want to download items.
If this option is turned on, nothing will be ask to user, and download can be processed as well very quickly...

A screenshot : http://www.flickr.com/photos/digikam/6028399563/sizes/o/in/photostream/

BUGS: 189903

M  +2    -1    utilities/setup/setup.h
M  +4    -0    utilities/cameragui/main/cameraui_p.h
M  +47   -11   utilities/cameragui/main/cameraui.cpp
M  +1    -0    utilities/setup/setupcamera.h
M  +18   -6    utilities/setup/setup.cpp
M  +39   -3    utilities/setup/setupcamera.cpp

http://commits.kde.org/digikam/891a9603e0f547d427375a98798343f276b98fa4