Bug 189794 - konqueror SIGABRT assert failure on exit
Summary: konqueror SIGABRT assert failure on exit
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: khtml (show other bugs)
Version: 4.2.2
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-16 13:10 UTC by Michael Kreitzer
Modified: 2009-04-17 16:36 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Kreitzer 2009-04-16 13:10:53 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    Unlisted Binary Package

I left konqueror open over night on the following page:

http://worldofgoogame.blogspot.com/2008/10/welcoming-unit-chapter-2-level-4.html

When I went to shut down the system the following morning konqueror crashed on exit with a SIGABRT. I do not know if the specific page is relevant, and this specific crash has not happened to me before. Backtrace follows:

Application: Konqueror (konqueror), signal SIGABRT
0x00007f3aba20d001 in nanosleep () from /lib/libc.so.6
[Current thread is 0 (LWP 4331)]

Thread 2 (Thread 0x7f3aa5de7950 (LWP 4995)):
#0  0x00007f3aba236d02 in select () from /lib/libc.so.6
#1  0x00007f3ab7dab5a6 in QProcessManager::run (this=0xb889e0) at io/qprocess_unix.cpp:305
#2  0x00007f3ab7cdaa92 in QThreadPrivate::start (arg=0xb889e0) at thread/qthread_unix.cpp:189
#3  0x00007f3ab6220fc7 in start_thread () from /lib/libpthread.so.0
#4  0x00007f3aba23d5dd in clone () from /lib/libc.so.6
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f3aba87e750 (LWP 4331)):
[KCrash Handler]
#5  0x00007f3aba1a00c5 in raise () from /lib/libc.so.6
#6  0x00007f3aba1a15e3 in abort () from /lib/libc.so.6
#7  0x00007f3aba1990e9 in __assert_fail () from /lib/libc.so.6
#8  0x00007f3aaba42bfc in KHTMLGlobal::finalCheck () at /usr/src/abs/kdelibs/src/kdelibs-4.2.2/khtml/khtml_global.cpp:258
#9  0x00007f3aa6c7c6c4 in ~KHTMLFactory (this=0x101ebf0) at /usr/src/abs/kdelibs/src/kdelibs-4.2.2/khtml/khtml_factory.cpp:35
#10 0x00007f3ab853bf87 in destroy () at /usr/include/QtCore/qalgorithms.h:350
#11 0x00007f3aba1a2c6d in exit () from /lib/libc.so.6
#12 0x00007f3aba18c54d in __libc_start_main () from /lib/libc.so.6
#13 0x0000000000400629 in _start ()
Comment 1 Dario Andres 2009-04-17 16:36:04 UTC
Thanks for reporting.

*** This bug has been marked as a duplicate of bug 151453 ***