Bug 189751 - Default playlist layout names are not translatable
Summary: Default playlist layout names are not translatable
Status: RESOLVED DUPLICATE of bug 189750
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.3-GIT
Platform: Compiled Sources Unspecified
: HI normal (vote)
Target Milestone: 2.3.0
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-15 22:37 UTC by Albert Astals Cid
Modified: 2010-01-22 23:27 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch to fix l10n for playlist layouts (761 bytes, patch)
2009-11-01 16:39 UTC, Kevin Funk
Details
Part of "amarok --debug" output on layouts (2.12 KB, text/plain)
2009-11-01 17:29 UTC, Yuri Chornoivan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Albert Astals Cid 2009-04-15 22:37:44 UTC
Version:            (using Devel)
Installed from:    Compiled sources

Default layout names (like "No Grouping") are not translatable
Comment 1 Albert Astals Cid 2009-04-15 22:39:57 UTC
See http://techbase.kde.org/Development/Tutorials/Localization/Building_KDE's_l10n_Module for how to use the x-test language for testing
Comment 2 Albert Astals Cid 2009-04-15 22:42:41 UTC
My suggestion:
 * Add to the xml a attribute that is default="true" for the ones that are shipped by default
 * Add to Messages.sh a way to parse the XML and extract the default values and store it in rc.cpp
 * When showing the layout name, check if it has the default="true" tag, if it has it, you pass the layout name thorugh i18n, if it has not, you just show it
 * User created layouts have default="false"
 * If a user edits a default layout it stops being a default layout so default goes to false too.
Comment 3 Lydia Pintscher 2009-05-05 13:19:39 UTC
Ian: I seem to remember you saying something about Plasma devs having a fix for this. Can you please comment?
Comment 4 Myriam Schweingruber 2009-08-02 16:39:49 UTC
Any news about this?
Comment 5 Myriam Schweingruber 2009-10-14 10:22:10 UTC
Bumb. This is old, could somebody comment on this, please?
Comment 6 Kevin Funk 2009-10-18 22:42:39 UTC
commit 5300a8328e1b0f9e90e95ff72e450e11b4c18447
Author: Kevin Funk <krf@electrostorm.net>
Date:   Sun Oct 18 22:39:43 2009 +0200

    Make playlist layouts translatable
    BR: 189751

Just before string freeze ;)
Comment 7 Albert Astals Cid 2009-10-18 23:21:36 UTC
That bug really doesn't fix the bug, thanks for working on it though :-)
Comment 8 Mark Kretschmann 2009-10-31 09:38:50 UTC
Our ChangeLog claims that this bug was fixed. KRF, what gives?
Comment 9 Yuri Chornoivan 2009-10-31 10:15:21 UTC
No, it is not fixed. Today's git build, Ukrainian, 100% translated. All layout names and fields are in English:
http://omploader.org/vMm50dQ/amarok.png
Comment 10 Mark Kretschmann 2009-10-31 10:20:29 UTC
So Kevin, what did your patch actually do then? :)

Maybe it should be reverted and the ChangeLog entry removed as well.
Comment 11 Kevin Funk 2009-11-01 05:09:26 UTC
Mark, my commit made it possible to translate the strings. However, the translated strings are not used in Amarok itself. The bug is not fixed yet, yep.
Comment 12 Kevin Funk 2009-11-01 16:39:46 UTC
Created attachment 38010 [details]
Patch to fix l10n for playlist layouts

Try to use the translated strings in Amarok.
Please test the attached diff as my l10n setup is horribly broken and cant test it locally. Please make sure the strings are already translated (check po file, etc.)
Comment 13 Yuri Chornoivan 2009-11-01 17:29:53 UTC
Created attachment 38011 [details]
Part of "amarok --debug" output on layouts
Comment 14 Yuri Chornoivan 2009-11-01 17:30:37 UTC
Applied to the last git-version (Ukrainian translation - messages 1389-1392 (layout names) are translated). Playlist is completely gone. All layout names ("Default", "No grouping", "Verbose") are gone as well. Only my own layout ("My") can be viewed in the list.

Screenshot:
http://omploader.org/vMm82dw/amarok1.png

Part of the debug output attached.
Comment 15 Kevin Funk 2009-11-02 20:45:41 UTC
Okay. No idea then, maybe Nikolaj has an idea how to work around this.
Comment 16 Myriam Schweingruber 2009-11-04 00:39:55 UTC
Nikolaj?
Comment 17 Stephen Baker 2010-01-22 22:36:12 UTC
Nikolaj Hald Nielsen (nhn@kde.org)
see #189750 (which looks like a dupe to me, but I'm not familiar with the issue)
Comment 18 Myriam Schweingruber 2010-01-22 23:27:16 UTC
Well spotted, Stephen.
Comment 19 Myriam Schweingruber 2010-01-22 23:27:46 UTC

*** This bug has been marked as a duplicate of bug 189750 ***