Bug 189555 - Way to change sort order of albums in "traditional" way
Summary: Way to change sort order of albums in "traditional" way
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Albums-Sort (show other bugs)
Version: 0.10.0
Platform: openSUSE RPMs Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-13 19:59 UTC by krienke
Modified: 2022-01-29 14:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description krienke 2009-04-13 19:59:24 UTC
Version:           0.10.0 (using KDE 4.2.2)
OS:                Linux
Installed from:    SuSE RPMs

In digikams regular album view showing folder icons for each album in left sidetab, albums are sorted by their name. In the menu "View->Sort albums" there is an option to change this sort oder. However choosing an option there eg. sort album by date then digikams left sidetab shows unexpectedly a completely different view on my albums. 

Now I do not see my albums like before (sorted by date) but I see a completely different calendar like view. This is not what I would expect when choosing "Sort albums by date" moreover its a duplicate of the calendar sidetab, duplicating its functionality.

The behaviour I would expect and that I am looking for is like in dolphin: Dolphin shows your folders (in digikam: albums) sorted by name and you can change the sort order eg to "by date" or whatever you like but you always have the same consistant view on your albums and files only their sort order changes. So here the view remains the same only the elements are displayed in different sort oder. There is no corresponding way to change sort order of albums in digikam because here the complete view on your albums changes.

Thank you very much
Rainer
Comment 1 Marcel Wiesweg 2009-04-14 14:49:37 UTC
What you see is a feature that deserves to be called ancient, together with the infamous album categories (from a time when there were neither tags nor any calendar view).
I support the wish to have albums sortable by name, date, maybe average date of images within as in any standard view.
Comment 2 caulier.gilles 2011-12-23 11:13:11 UTC

*** This bug has been marked as a duplicate of bug 156186 ***
Comment 3 caulier.gilles 2022-01-29 14:48:12 UTC
Fixed with https://bugs.kde.org/show_bug.cgi?id=156186