Bug 189058 - konsole copies lot of extra trailing spaces to clipboard (when operating with large amount of text?)
Summary: konsole copies lot of extra trailing spaces to clipboard (when operating with...
Status: RESOLVED DUPLICATE of bug 188528
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-07 19:36 UTC by Tamás Németh
Modified: 2009-04-29 17:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tamás Németh 2009-04-07 19:36:00 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    SuSE RPMs

If I issue for example a 'cat <FILENAME>' command in a konsole window, and the
select all the text and copy it to the clipboard, every line (in the clipboard)
will be tailed with space characters in order to be equally long (perhaps as
wide the konsole windows is). KDE3's konsole was more intelligent and copyied
every line only until its end onto the clipboard. The new konsole's behaviour
makes it very difficult for sysadmins to compare configuration files, etc.

Initially, I thought that it only happens with huge Cisco router config files, but recently it also happened in pure Linux environment, when working with an LDIF file.

See also:

https://bugzilla.novell.com/show_bug.cgi?id=445642
Comment 1 Kurt Hindenburg 2009-04-29 17:06:34 UTC

*** This bug has been marked as a duplicate of bug 188528 ***