Bug 189009 - Pressing PageUp or PageDown should never change the current feed.
Summary: Pressing PageUp or PageDown should never change the current feed.
Status: RESOLVED WORKSFORME
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Unspecified
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-07 06:03 UTC by Christoph Bartoschek
Modified: 2014-01-08 21:51 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Bartoschek 2009-04-07 06:03:48 UTC
Version:            (using KDE 4.2.2)
Installed from:    SuSE RPMs

The following happens quite often to me and is very annoying:

Prerequisites:
1. I have a feed with an unread message that is longer than the preview window.
2. The '+' key advances to the next unread message over all feeds.

How to reproduce:
1. Click on a feed in the feed list that is not the last one in the list.
2. Press the '+' key once or twice to get to the next unread message.
3. After reading the first part of the message press PageDown to see the rest of the message.
4. Suddenly the message disappears because akregator has changed the feed.

Apparently the feed list has still the focus for the PageDown key and not the message itself. This is wrong. After pressing the '+' key the message should get the focus such that PageDown and PageUp are bound to the message.

The same holds true for the  Up-Key and Down-Key.

Actually I do not see any reason why one would like to navigate the feed list with the PageUp and PageDown or the up and down keys.

The message list for a feed does not show the problem. This is only true for the feed list.
Comment 1 Ray Charles 2009-04-12 02:02:14 UTC
I can confirm this, this is really annoying
Comment 2 Ricardo J. Barberis 2014-01-07 01:25:46 UTC
This seems to have been fixed sometime between KDE SC 4.8.5 (reproducible) and 4.11.4 (no longer reproducible), so I believe this bug can be closed.