Bug 188764 - Ambiguous shortcuts in all actions when starting Kate with split views
Summary: Ambiguous shortcuts in all actions when starting Kate with split views
Status: RESOLVED REMIND
Alias: None
Product: kate
Classification: Unclassified
Component: general (show other bugs)
Version: 20.12.1
Platform: Neon Packages Linux
: VHI normal with 120 votes (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
: 215805 236480 274155 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-04-03 19:58 UTC by Dima Ryazanov
Modified: 2021-05-17 01:07 UTC (History)
15 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dima Ryazanov 2009-04-03 19:58:38 UTC
Version:            (using KDE 4.2.2)
OS:                Linux
Installed from:    Ubuntu Packages

I just upgraded to KDE 4.2.2. I can't use most of the shortcuts in Kate anymore - such as Ctrl+S, Ctrl+F, Ctrl+G.

I get the message:

"The key sequence 'Ctrl+S' is ambiguous. Use 'Configure Shortcuts' from the 'Settings' menu to solve the ambiguity.
No action will be triggered."

The shortcuts dialog only has one action for each shortcut. All of them are set to defaults. But if I try to set a custom Ctrl-S shortcut for "Save", I get the error:

"The "Ctrl+S" shortcut is ambiguous with the following shortcuts.
Do you want to assign an empty shortcut to these actions?
Shortcut(s) 'Ctrl+S' for action 'Save'"

What does it even mean? What "following shortcuts"?
Comment 1 Dima Ryazanov 2009-04-03 20:03:58 UTC
Btw, it only happens in my default session. If I create a new one, shortcuts start working fine.
Comment 2 Dima Ryazanov 2009-04-03 20:57:16 UTC
Deleting the following lines from the .session file fixes it:

[MainWindow0-Splitter 0]
Children=MainWindow0-ViewSpace 0,MainWindow0-ViewSpace 1
Orientation=1
Sizes=951,809
Comment 3 Jim Higson 2009-05-03 11:39:41 UTC
I'm getting exactly the same since I went to KDE4. Very annoying bug.

Thanks for the workarround, will this be fixed?
Comment 4 Jim Higson 2009-05-03 11:46:58 UTC
I can confirm that the workaround makes the problem go away.

For info, the files are in: ~/.kde/share/apps/kate/sessions and called something like: foo.katesession

Thanks again, until now I've been restarting projects in Kate from scratch (not the code, the project!)
Comment 5 Dima Ryazanov 2009-06-03 20:38:12 UTC
Just upgraded to KDE 4.2.4 - and all the shortcuts are ambiguous *again*.
Comment 6 Bruce Miller 2009-07-06 06:13:15 UTC
This problem also exists in Konqueror 4.2.95 == 4.3RC

The ambiguity appears to arise from the presence of both a "kate part" and a "konqueror part" in the list of shortcuts
Comment 7 Dima Ryazanov 2009-09-22 20:42:40 UTC
I got this problem in Kate yet again after changing Kate's language.
Comment 8 Dima Ryazanov 2009-11-10 22:26:37 UTC
Got this problem again... Not sure what triggered it.
Now, though, I've deleted the session file - but it didn't make a difference. Same problem, and Kate still shows me my session.

Also, it insists on creating the file:
~/.kde/share/apps/kate/sessions/usr/share/kde4/apps/kate/default.katesession
What's up with /usr/share/kde4/...?
Comment 9 Philipp A. 2009-11-12 14:52:51 UTC
workaround does not work anymore in kubuntu karmic / kde 4.3
(i have the issue now)

while the description of bug 200259 fits better, this one has more votes. can somebody PLEASE confirm one of them?
Comment 10 Dominik Haumann 2009-11-23 23:21:20 UTC
*** Bug 215805 has been marked as a duplicate of this bug. ***
Comment 11 Iñaki Baz Castillo 2009-11-23 23:50:33 UTC
Annoying bug which makes it difficult to work with Kate :(
Comment 12 Frank Schwach 2009-11-25 20:11:57 UTC
I have the same problem. I noticed that the ambiguity is resolved if I create a new, empty list of shortcuts in 'configure shortcuts', so now when I have the problem (which seems sporadic as described by others) I switch to the empty list
Comment 13 Dima Ryazanov 2009-11-25 20:23:52 UTC
*** This bug has been confirmed by popular vote. ***
Comment 14 Philipp A. 2009-12-05 14:26:37 UTC
the name used in shortcut-xml-files is "focus_search_bar".
nothing changes, however, if you set it to "" in ~/.kde/share/apps/konqueror/konquerorDefaultshortcuts.rc and/or ~/.kde/share/apps/konqueror/konqueror.rc

i loathe this bug so much i would squish it under my heel if i got near to it, but the shortcut-settings are so hopelessly buggy i doubt there will be a fix ever.
Comment 15 Dima Ryazanov 2010-03-03 03:53:58 UTC
Same thing again, after upgrading to KDE 4.4.1.
Comment 16 Bruce Miller 2010-03-03 04:52:24 UTC
This problem has historically infacted more KDE applications than just kate. I have experienced it most frequently with konqueror. It is back in Kubuntu 4.4.0.
Comment 17 Dominik Haumann 2010-06-20 11:44:08 UTC
*** Bug 236480 has been marked as a duplicate of this bug. ***
Comment 18 Dominik Haumann 2010-06-20 11:46:40 UTC
Ok, this is mainly about spit view: If you start kate and splitted views are
restored, you always get that. If you click in all views once, all works fine
again. Of course, needs to be fixed...

related: bug #236368
Comment 19 Jonas 2010-08-15 12:49:45 UTC
I can also confirm this bug. For what it's worth, I had two splits in my default session, but when I started Kate it wasn't splitted. When I checked files that I know have been splitted, in the Documents sidebar, they seem to be unsplitted (can't recall if that's the default action). Anyway, it was all a bit strange.
Comment 20 Martin M 2010-08-26 10:32:38 UTC
(In reply to comment #18)
I confirm both this bug and the workaround proposed by Dominik. Clicking once in all views of the split view setup makes all work again.
Comment 21 Lars Winterfeld 2010-11-21 17:26:31 UTC
see also https://bugs.kde.org/show_bug.cgi?id=227618

i can confirm the bug in kate version 3.4.5 using kde 4.4.5 .

i guess it happens when a split-view session is loaded. solution for me was to close the split view and open it again.
Comment 22 Iñaki Baz Castillo 2010-11-21 17:31:08 UTC
(In reply to comment #21)
> i guess it happens when a split-view session is loaded. solution for me was to
> close the split view and open it again.

An easier "solution" (a workaround) is clicking with the mouse in all the split views.
Comment 23 Con Kolivas 2011-03-28 12:26:47 UTC
Still there kde 4.6
Comment 24 Joe Mulloy 2011-04-06 02:53:47 UTC
Also seeing this in KDE 4.6.0 on OpenSuse 11.4
Comment 25 felix_mauch 2011-04-08 15:49:27 UTC
still in 4.6.2
Comment 26 Niklas Laxström 2011-06-02 10:44:17 UTC
Still in 4.6.3. There wasn't even any visible indication that the view was split.
Comment 27 Dominik Haumann 2011-06-28 19:32:08 UTC
*** Bug 274155 has been marked as a duplicate of this bug. ***
Comment 28 Dominik Haumann 2011-08-13 18:09:30 UTC
Git commit b9f62f8c87dd96c5a0f70f47b116e24cd68ca796 by Dominik Haumann.
Committed on 13/08/2011 at 20:07.
Pushed by dhaumann into branch 'master'.

fix ambiguous shortcuts after session restore

CCBUG: 195435
BUG: 188764

M  +3    -3    kate/app/kateviewmanager.cpp

http://commits.kde.org/kate/b9f62f8c87dd96c5a0f70f47b116e24cd68ca796
Comment 29 Dominik Haumann 2011-08-13 18:21:12 UTC
Git commit 2c4091150cc8b5f45c042bedc329227f20e5815f by Dominik Haumann.
Committed on 13/08/2011 at 20:07.
Pushed by dhaumann into branch 'KDE/4.7'.

fix ambiguous shortcuts after session restore

CCBUG: 195435
BUG: 188764

M  +3    -3    kate/app/kateviewmanager.cpp

http://commits.kde.org/kate/2c4091150cc8b5f45c042bedc329227f20e5815f
Comment 30 Enmk 2021-02-11 10:36:39 UTC
This bug recently reappeared for me while editing a markdown document with a live preview. 

Occasionally either Ctrl+F, Ctrl+S, or Ctrl+C stop working, which is a huge inconvenience. Nothing suspicious in the settings, i.e., no keybindings dublicates.

Kate
Version 20.12.1

KMarkdownWebViewPart
Version 0.5.6

Operating System: KDE neon 5.20
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2
Kernel Version: 5.4.0-65-generic
OS Type: 64-bit
Processors: 12 × Intel® Core™ i7-8750H CPU @ 2.20GHz
Memory: 31,0 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630
Comment 31 Armin 2021-05-17 01:07:01 UTC
@Enmk: Have a look at https://bugs.kde.org/show_bug.cgi?id=386265. This seems relevant and the discussion there seems to be more on track to hunt this down than this 10 year old bug.