Bug 188403 - Konqueror crashed on close (from Youtube)
Summary: Konqueror crashed on close (from Youtube)
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: 4.2.1
Platform: Gentoo Packages Unspecified
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-29 16:06 UTC by Marcus Harrison
Modified: 2009-03-29 23:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcus Harrison 2009-03-29 16:06:18 UTC
Version:            (using KDE 4.2.1)
Installed from:    Gentoo Packages

When on Youtube, the NSPluginViewer loaded properly, all was well. After closing the window, I got a crash with this backtrace:

Application: Konqueror (konqueror), signal SIGABRT
[Current thread is 0 (LWP 28226)]

Thread 2 (Thread 0xb2263b90 (LWP 28228)):
#0  0xb8095424 in __kernel_vsyscall ()
#1  0xb66990a1 in select () from /lib/libc.so.6
#2  0xb7383cc7 in QProcessManager::run (this=0x9f1e0d0) at io/qprocess_unix.cpp:305
#3  0xb72b4ae0 in QThreadPrivate::start (arg=0x9f1e0d0) at thread/qthread_unix.cpp:189
#4  0xb7234170 in start_thread (arg=0xb2263b90) at pthread_create.c:297
#5  0xb669fd4e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb6046920 (LWP 28226)):
[KCrash Handler]
#6  0xb8095424 in __kernel_vsyscall ()
#7  0xb65fb670 in raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#8  0xb65fceb8 in abort () at abort.c:88
#9  0xb65f46ee in __assert_fail (assertion=0xb462e3a2 "!s_refcnt", file=0xb462e1a4 "/var/tmp/portage/kde-base/kdelibs-4.2.1-r3/work/kdelibs-4.2.1/khtml/khtml_global.cpp", line=258, 
    function=0xb462e3e0 "static void KHTMLGlobal::finalCheck()") at assert.c:78
#10 0xb421a437 in KHTMLGlobal::finalCheck () at /var/tmp/portage/kde-base/kdelibs-4.2.1-r3/work/kdelibs-4.2.1/khtml/khtml_global.cpp:258
#11 0xb7247430 in ~KHTMLFactory (this=0xa240978) at /var/tmp/portage/kde-base/kdelibs-4.2.1-r3/work/kdelibs-4.2.1/khtml/khtml_factory.cpp:35
#12 0xb769ce27 in destroy () at /usr/include/qt4/QtCore/qalgorithms.h:350
#13 0xb753aeeb in ~KCleanUpGlobalStatic (this=0xb76f9164) at /var/tmp/portage/kde-base/kdelibs-4.2.1-r3/work/kdelibs-4.2.1/kdecore/kernel/kglobal.h:62
#14 0xb65fe551 in exit (status=0) at exit.c:75
#15 0xb65e772d in __libc_start_main (main=0x8048820 <main>, argc=2, ubp_av=0xbff96804, init=0x8048870 <__libc_csu_init>, fini=0x8048860 <__libc_csu_fini>, rtld_fini=0xb8088150 <_dl_fini>, 
    stack_end=0xbff967fc) at libc-start.c:258
#16 0x08048761 in _start ()
Comment 1 Dario Andres 2009-03-29 23:41:19 UTC
Thanks for reporting

*** This bug has been marked as a duplicate of bug 151453 ***