Bug 188377 - amixer + keytouch with alt-tab cause kwin to crash
Summary: amixer + keytouch with alt-tab cause kwin to crash
Status: RESOLVED DUPLICATE of bug 179865
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-29 04:26 UTC by Leonid Grinberg
Modified: 2009-03-29 12:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
The output from xprop when ran on keytouch's amixer window (1.47 KB, text/plain)
2009-03-29 04:27 UTC, Leonid Grinberg
Details
Output from the debugger when kwin crashes. (3.04 KB, text/plain)
2009-03-29 04:28 UTC, Leonid Grinberg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leonid Grinberg 2009-03-29 04:26:22 UTC
Version:            (using KDE 4.2.1)
OS:                Linux
Installed from:    Unlisted Binary Package

There is a program called keyTouch (http://keytouch.sourceforge.net/). Though fairly obscure, it is useful to some people because it recognises media keys found on certain laptops out of the box, that KDE either doesn't recognise easily or at all. Default behaviour for volume keys is to run amixer to change the volume. This causes a little box to appear that says "Volume X%", with an appropriate amount of the box filled in. The box has no window decorations and disappears within a few seconds. It doesn't appear in Plasma's window list in the panel.

However, due to what appears to be outdated KDE code in the source, alt-tab'ing produces unfortunate results. Specifically, if one changes the volume and then alt-tab's quickly enough, the volume box will appear in the list of windows. Kwin will then hang for a moment or two and promptly crash.

I am running vanilla 4.2.1 on Arch Linux. Attached are output from gdb as well as output from xprop (the xprop being run on the little volume box that appears).

Steps to reproduce:

1) Install keytouch (http://keytouch.sourceforge.net/) and run keytouchd. Make sure that it's configured to use amixer to change volumes as necessary.
2) Press the button to which you mapped, e.g. volume-down
3) As soon as the box appears, hit alt-tab (or whatever shortcut is used for window switching). If you did it correctly, you will see the volume box in the window switcher, which will cause kwin to crash. This step might take a few times to get correctly, as timing is important.
Comment 1 Leonid Grinberg 2009-03-29 04:27:51 UTC
Created attachment 32455 [details]
The output from xprop when ran on keytouch's amixer window
Comment 2 Leonid Grinberg 2009-03-29 04:28:48 UTC
Created attachment 32456 [details]
Output from the debugger when kwin crashes.
Comment 3 Leonid Grinberg 2009-03-29 04:45:22 UTC
Oh, for what it's worth, as the stack trace indicates, I had compositing on when I noticed this. Without compositing, this doesn't happen.
Comment 4 Martin Flöser 2009-03-29 12:10:12 UTC

*** This bug has been marked as a duplicate of bug 179865 ***