Bug 188369 - Cannot open images with non-ASCII characters
Summary: Cannot open images with non-ASCII characters
Status: CLOSED DUPLICATE of bug 186038
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-29 00:14 UTC by Zdeněk Zikán
Modified: 2012-10-19 13:26 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Gwenview interpreting non-ASCII character incorrectly (33.19 KB, image/png)
2009-03-29 00:15 UTC, Zdeněk Zikán
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zdeněk Zikán 2009-03-29 00:14:15 UTC
Version:           2.2.0 (using KDE 4.2.1)
OS:                Linux
Installed from:    Ubuntu Packages

I have file called "březen.jpg" (but it seems to fail for any non-ASCII characters). If I open Gwenview with the filename as a parameter, e.g. by clicking on it in file manager or running "gwenview březen.jpg", Gwenview only displays error message included in the attachment. It's obvious that it cannot handle "ř" character correctly. However, if I navigate into that folder in Gwenview and open the file there, or use File->Open dialog in Gwenview it works.
Comment 1 Zdeněk Zikán 2009-03-29 00:15:15 UTC
Created attachment 32453 [details]
Gwenview interpreting non-ASCII character incorrectly
Comment 2 Jonas Vejlin 2009-03-30 12:49:06 UTC
I can confirm this bug running debian sid/experimental with kde 4.2.1 and 2.2.0    of  gwenview
Comment 3 Aurelien Gateau 2009-04-27 15:53:27 UTC
If I am not mistaken, the bug is in kdelibs and has been fixed in 4.2.2. I can't find the bug report though.
Comment 4 Aurelien Gateau 2009-04-27 15:57:38 UTC
Found the original report.

*** This bug has been marked as a duplicate of bug 186038 ***
Comment 5 Zdeněk Zikán 2009-04-27 16:05:59 UTC
Confirming, that in the latest stable KDE 4.2.2 (with Gwenview 2.2.2) the bug is fixed. Setting the bug as closed.