Bug 187934 - Task manager freezes when trying to "safely remove" busy storage volume
Summary: Task manager freezes when trying to "safely remove" busy storage volume
Status: RESOLVED DUPLICATE of bug 187242
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 190922 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-03-23 18:05 UTC by jem
Modified: 2009-04-28 16:57 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jem 2009-03-23 18:05:33 UTC
Version:            (using KDE 4.2.1)
Compiler:          x86_64-pc-linux-gnu-gcc (Gentoo 4.3.3-r1 p1.1, pie-10.1.5) 
OS:                Linux
Installed from:    Gentoo Packages

If you try to remove a storage volume that is busy using the "Devices recently plugged in" widget, the widget and the whole task manager bar (including Kickoff) freezes.

To repeat: plug in and open a USB drive. Open a console and cd into a directory on the drive. Click on the eject button in the widget.

Expected behaviour: an error message that the volume is busy and can't be removed.

And while we're at it: a more visible feedback giving permission to remove the volume when it is ok is very much needed. It took me quite a while before I realized a checkmark is displayed to signify this.
Comment 1 Dario Andres 2009-03-25 16:10:53 UTC
Thanks for reporting

*** This bug has been marked as a duplicate of bug 187242 ***
Comment 2 Artur Souza (MoRpHeUz) 2009-04-28 16:57:24 UTC
*** Bug 190922 has been marked as a duplicate of this bug. ***