Bug 187875 - vim set columns does not work properly
Summary: vim set columns does not work properly
Status: RESOLVED DUPLICATE of bug 245746
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Slackware Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-22 18:55 UTC by the_shark
Modified: 2011-03-06 20:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description the_shark 2009-03-22 18:55:32 UTC
Version:            (using KDE 4.2.1)
OS:                Linux
Installed from:    Slackware Packages

I've found this bug in konsole using vim.

If you open vim on a konsole, and you want to choose the size of the columns you just have to do

:set columns=x

where x is the number of columns.

With xterm (for example) when you choose for example 80 it automatically resize xterm to have 80 columns only.

In konsole it breaks vim and the konsole.

What I mean with "breaks" is that sometimes you cannot see what you type, ether in vim and in konsole, and also the reset command does not work, so you've to close the konsole.
Comment 1 Kurt Hindenburg 2011-03-06 20:12:13 UTC
Adding as as a dup to 245746 since that has a test case.

*** This bug has been marked as a duplicate of bug 245746 ***