Bug 187768 - lilypond-generated textedit urls with accented characters don't work
Summary: lilypond-generated textedit urls with accented characters don't work
Status: RESOLVED DUPLICATE of bug 186038
Alias: None
Product: okular
Classification: Unclassified
Component: general (show other bugs)
Version: 0.8.1
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-21 08:28 UTC by Wilbert Berendsen
Modified: 2009-03-21 10:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wilbert Berendsen 2009-03-21 08:28:10 UTC
Version:           0.8.1 (using KDE 4.2.1)
OS:                Linux
Installed from:    Ubuntu Packages

I have a LilyPond file called "tëst.ly" (i.e. with an accented character in it). When I run LilyPond on it, it generates a PDF with embedded textedit:// urls that point to the source document.

But LilyPond always encodes filenames in textedit:// URLs in UTF-8 encoding.

The problem is that Okular does not know that and so does not find the file and does not call the editor.

Possible solutions:
- don't test for existence of the file, just call the editor and let the editor try to open the file
- perform the conversion from UTF-8 once (using something like QString::fromUtf8(url.toLatin1()))
Comment 1 Pino Toscano 2009-03-21 10:16:48 UTC

*** This bug has been marked as a duplicate of bug 186038 ***