Bug 187627 - Some GTK applications' system tray icon are not displaying in KDE 4
Summary: Some GTK applications' system tray icon are not displaying in KDE 4
Status: RESOLVED DUPLICATE of bug 164786
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-19 19:42 UTC by Dotan Cohen
Modified: 2009-03-20 00:20 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dotan Cohen 2009-03-19 19:42:50 UTC
Version:            (using KDE 4.2.0)
Installed from:    Ubuntu Packages

It appears that some GTK applications' tray icons are not appearing in KDE 4. An example of this is Zim:
http://zim-wiki.org/

On the Zim bugtracker there is a reduced test case that KDE 4 fails to show the tray icon for:
http://launchpadlibrarian.net/23696002/test-trayicon.py
Comment 1 Aaron J. Seigo 2009-03-19 20:56:08 UTC
depends on the version of qt (e.g. known issues with 4.4.1) and which sys tray it is. works fine in trunk and branch, though with latest Qt versions for each.

*** This bug has been marked as a duplicate of bug 164786 ***
Comment 2 Dotan Cohen 2009-03-19 22:11:36 UTC
Are you sure it's fixed, or related? I'm running more recent software than there was when that bug was closed, that's why I thought that it might not be related:

$ kde4-config -v
Qt: 4.5.0
KDE: 4.2.1 (KDE 4.2.1)
kde4-config: 1.0

Could you try the testcase linked above on Trunk to confirm, as I cannot build it here (production machine)?

Thanks, Aaron!
Comment 3 Aaron J. Seigo 2009-03-19 23:52:36 UTC
i used to be able to reproduce with 100% reliability with pretty much exactly the same test case (only in perl, but same difference), and it was eventually fixed. whether that was in our code, qt, or gtk .. i don't know.
Comment 4 Dotan Cohen 2009-03-20 00:20:44 UTC
Alright, then, I'll wait it out until I can get newer software versions. Thanks for the explanation, it really shows that you care about making a good user experience and not just getting bugs closed quickly. Your work is much appreciated, Aaron.