Bug 187175 - Can not resize columns in the folder list
Summary: Can not resize columns in the folder list
Status: RESOLVED FIXED
Alias: None
Product: kmail
Classification: Unclassified
Component: new folder tree (show other bugs)
Version: 1.11.1
Platform: unspecified Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Szymon Stefanek
URL:
Keywords:
: 190170 192782 (view as bug list)
Depends on:
Blocks:
 
Reported: 2009-03-14 21:07 UTC by Daniel
Modified: 2009-11-01 08:45 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2009-03-14 21:07:10 UTC
Version:           1.11.1 (using 4.2.1 (KDE 4.2.1), volkerdi@slackware.com)
Compiler:          gcc
OS:                Linux (i686) release 2.6.28.7-smp

1. Right-click on the column title in the folder list. A menu pops up.
2. Under "View Columns" turn on the "Total" column.
3. Can not resize the columns. The mouse cursor won't even turn to the resize icon. <- This is the bug.
Comment 1 Jaime Torres 2009-03-14 22:54:54 UTC
This works for me in kde 4.2.65.
Comment 2 Thomas McGuire 2009-03-18 23:42:13 UTC
Szymon and Albert can reproduce this,actually. (I can not)
Comment 3 Michael Reiher 2009-04-02 17:47:57 UTC
Same here with KDE 4.2.2 (Kubuntu Jaunty). It also doesn't seem to be a general problem with this kind of widget, e.g. resizing columns in aggregator works fine.
Comment 4 Jaime Torres 2009-04-20 17:44:26 UTC
*** Bug 190170 has been marked as a duplicate of this bug. ***
Comment 5 Unknown 2009-04-20 20:56:35 UTC
I have the same issue, too (KDE 4.2.2, Kubuntu 9.04 RC).
However, KMail is not the only application for me - the task manager I can start for KRunner also prevents resizing the first column (the one with the name of the process). All other columns can be resized without problems.
Comment 6 Ronny Standtke 2009-04-30 10:01:15 UTC
Bug confirmed with Kubuntu 9.04 final.
Comment 7 reinhard.zwirnmann 2009-05-07 09:07:01 UTC
I can confirm this behaviour for KDE 4.2.2 and 4.2.3 in openSUSE 11.1
It is not possible to adjust the column width in the folder view, if you have 2 columns each of them has a width of 50%. In the message view it's no problem...
Comment 8 Olivier Trichet 2009-05-12 23:17:35 UTC
SVN commit 967210 by otrichet:

Do not restore the ResizeMode of tree view

CCBUG: 187175

 M  +12 -4     treewidget.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=967210
Comment 9 Thomas McGuire 2009-05-13 15:16:19 UTC
SVN commit 967443 by tmcguire:

Backport r967210 by otrichet from trunk to the 4.2 branch:

Do not restore the ResizeMode of tree view

CCBUG: 187175


 M  +12 -4     treewidget.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=967443
Comment 10 Dario Andres 2009-05-15 16:56:40 UTC
*** Bug 192782 has been marked as a duplicate of this bug. ***
Comment 11 markuss 2009-06-01 00:19:21 UTC
This bug somehow got worse in 4.3b1.
Comment 12 Antonio Rojas 2009-06-03 11:13:32 UTC
(In reply to comment #11)
> This bug somehow got worse in 4.3b1.

I agree this got worse in 4.2.4 too. Now the last column is always hidden beyond the right border of the folder list, and there is no way to make it show: resizing the folder list just makes the last column move further to the right. It looks like it is trying to auto-resize the columns but it thinks the folder pane is larger than it actually is.
Comment 13 Michael Reiher 2009-06-03 23:07:18 UTC
I just upgraded to 4.2.4 and things actually seem a lot better now :) On first start only the Folder was visible. I readded Unread and Total and I can resize them and everything is fine. 

Only the Size column (which I didn't even know it existed up to now) has a little problem: only half of it is visible, the rest can be reached only by using the scrollbar. Probably same as in comment #12.

Hmm, looking at it more closely also without the Size column there is a problem with the last column (Total in this case). Only that it's just a few pixels here, so it's hardly visible. The basic problem seems to be the same however.
Comment 14 Ferdinand Gassauer 2009-06-21 21:52:05 UTC
OpenSuSE KDE 4.2.90  4.3 Beta2 release 138
2 columns (Folder , unread) are visible  but do not extend over the full width.

trying to move the right most splitter to the right actually moves the middle splitter to the left while the right splitter does not move
after removing "unread" the Folder column extends over the full width.

nevertheless trying to move the right splitter to the left moves the middle splitter to the right
Comment 15 greatbunzinni 2009-07-02 21:21:16 UTC
This behaviour is still present in kmail 1.11.90 from KDE 4.3 RC1
Comment 16 Ralf Jung 2009-07-28 21:45:14 UTC
I'm using KDE 4.2.4 and have the same problem.
Comment 17 Oren Held 2009-08-01 22:39:31 UTC
I really think this one is related to bug 195940, which will is already fixed (unfortunately only in 4.3)
Comment 18 plabo 2009-08-07 16:03:26 UTC
I agree with  Oren, this bug turned into the mentioned bug

And yes, also for me, starting with 4.3 everything is fine (I can resize the columns and have no scroll bar)

opensuse 11.1, KDE 4.3.00 (KDE:/KDE4:/Factory:/
Comment 19 Ronny Standtke 2009-10-31 22:23:57 UTC
I can confirm that this bug is fixed for me in KDE-4.3.2 (Kubuntu-9.10). I just can not change the status of this bug report...
Comment 20 Daniel 2009-11-01 08:45:38 UTC
fixed, thanks.