Bug 187148 - cannot open file with "malformed" filename
Summary: cannot open file with "malformed" filename
Status: RESOLVED DUPLICATE of bug 186038
Alias: None
Product: okular
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-14 15:57 UTC by Maciej Pilichowski
Modified: 2009-03-14 17:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Pilichowski 2009-03-14 15:57:20 UTC
Version:            (using KDE 4.2.1)
Installed from:    SuSE RPMs

Malformed -- contains character which is displayed as uknown character "?".

Such file can be opened and viewed by any tool -- MC, more, you name it -- it is listed by Konqueror, open dialog, dir, etc. Yet after opening the file (i.e. try to open) okular just displays message error that it cannot open such file.

After removing such characters it is possible to open the file.
Comment 1 Pino Toscano 2009-03-14 16:04:35 UTC

*** This bug has been marked as a duplicate of bug 186038 ***
Comment 2 Maciej Pilichowski 2009-03-14 17:20:29 UTC
I am not sure my report is a duplicate:
* I _can_ open files from file->open for utf-8 filenames
* I _cannot_ open files from file->open for malformed filenames, i.e. filename that contain "?" characters (I believe this means it is not legal character).

Of course I can tell for sure after KDE4.2.2 release.