Bug 186760 - KDE4 can't work with non english filenames
Summary: KDE4 can't work with non english filenames
Status: RESOLVED DUPLICATE of bug 186038
Alias: None
Product: kde
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-10 12:08 UTC by kostiagol
Modified: 2009-03-10 13:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kostiagol 2009-03-10 12:08:07 UTC
Version:            (using KDE 4.2.1)
OS:                Linux
Installed from:    Debian testing/unstable Packages

Can't open files and folders with non english names(checked with Russian and Lithuanian language) This bug first appeared in KDE3, but then fixed, in kde4.0 appeared again, but now (4.2.1 with qt4.5) even worse.
Here's an example:
Create folder "общедоступные" in home directory, put in files (jpeg, pdf, any) and try to open it with kde application. It will give you an error - can't open file. If you try to open file with gnome app, it works.
As I understand apps ignore non english letters
KDE apps been checked:
ark, digikam, showfoto, okular, koffice, all kde apps...
Amarok can play files, but collection list has gone after update, because files stored in folder "Музыка". But juk can play files, and create collection list.
ksysguard - original russian names of tabs and sensors are shown, but when I try to create my own tab , with my own names, it shows only ?????? ???? ??

I use Debian, encoding by default (utf-8), locales: russian, lithuanian.
KDE from experimental repository.
in russian forum one guy said that in Gentoo, compilling without -iconv solved problem. But I don't know if it's true.
Comment 1 Jonathan Thomas 2009-03-10 13:30:42 UTC

*** This bug has been marked as a duplicate of bug 186038 ***