Bug 186572 - seems to ignore locale setting
Summary: seems to ignore locale setting
Status: RESOLVED DUPLICATE of bug 186038
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 16.12.2
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-08 18:27 UTC by Nadav Kavalerchik
Modified: 2009-03-08 19:59 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nadav Kavalerchik 2009-03-08 18:27:16 UTC
Version:           unknown (using 4.2.1 (KDE 4.2.1), Debian packages)
Compiler:          cc
OS:                Linux (x86_64) release 2.6.26-1-amd64

i am starting dolphin from konsole like this:
"LANG=he_IL.UTF-8 dolphin"
and it starts in english ui .

i see filenames in hebrew properly, even when i start dolphin without setting the LANG variable.

clicking on hebrew filenames i get an error opening them with any kde application although opening an image with an hebrew filename using the gimp opens up with no error (seems GNOME handle it properly)

this phenomena is quite new. it used to work just fine.
i am upgrading my system quite frequently so it might be related to some package upgrade. but, i do not know which one.

seems the encoding is wrong. (as i look at the filenames error dialog)
Comment 1 Jonathan Thomas 2009-03-08 19:59:27 UTC

*** This bug has been marked as a duplicate of bug 186038 ***