Bug 186536 - when checking mail, kmail spends hours going through old messages
Summary: when checking mail, kmail spends hours going through old messages
Status: RESOLVED DUPLICATE of bug 84162
Alias: None
Product: kmail
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Unspecified
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-08 12:32 UTC by Nicolas L.
Modified: 2009-07-22 21:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas L. 2009-03-08 12:32:48 UTC
Version:            (using KDE 4.2.1)
Installed from:    Mandriva RPMs

Mandriva bugreport : https://qa.mandriva.com/show_bug.cgi?id=48561

...
...
kmail(616)/kmail (storage internals) KMFolderMaildir::getDwString:
KDE_fopen(abs_file=
"/home/hajma/.kde/share/apps/kmail/mail/.atropikhajma.directory/.mandriva.directory/.cooker.directory/2007/cur/1167848836.25269.TgzcQ:2,S"
, "r+") == stream ==  0x9e58fc0
kmail(616)/kmail (storage internals) KMFolderMaildir::getDwString:
fclose(mIndexStream =  0x9e58fc0 )
kmail(616)/kmail (storage internals) KMFolderMaildir::getDwString: 
To reproduce:
launch kmail
hit the Check messages button

result:
as soon as kmail starts to receive the emails from server, it apparently tries
to check all the emails stored locally. With 50k+ mails this takes more than an
hour on a 1.6Ghz 1.5GB RAM laptop, during which neither kmail not the PC are
really usable. iostat reports that kmail is accessing the drive at a constant
300kB/s rate. The below messages are constantly printed to konsole when kmail
is run from konsole:

KDE_fopen(abs_file=
"/home/hajma/.kde/share/apps/kmail/mail/.atropikhajma.directory/.mandriva.directory/.cooker.directory/2007/cur/1167848841.25269.6Hy6s:2,S"
, "r+") == stream ==  0x9e58fc0
kmail(616)/kmail (storage internals) KMFolderMaildir::getDwString:
fclose(mIndexStream =  0x9e58fc0 )
kmail(616)/kmail (storage internals) KMFolderMaildir::getDwString:
KDE_fopen(abs_file=
"/home/hajma/.kde/share/apps/kmail/mail/.atropikhajma.directory/.mandriva.directory/.cooker.directory/2007/cur/1167848846.25269.C0MJG:2,S"
, "r+") == stream ==  0x9e58fc0
...
...
Comment 1 tropikhajma 2009-03-11 20:41:55 UTC
this only happens the first time after launching kmail
however when i close kmail  and launch  it again, it happens again
Comment 2 tropikhajma 2009-03-29 08:54:29 UTC
same in kde 4.2.2
Comment 3 tropikhajma 2009-06-24 22:12:09 UTC
thanks for the interest from the developers...
I'm just moving all my mails to Thunderbird
Comment 4 Christophe Giboudeaux 2009-07-22 21:52:54 UTC

*** This bug has been marked as a duplicate of bug 84162 ***