Bug 186386 - Openning of files with national characters from dolphin, krusader doesn't work after upgrade of Qt libraries to 4.5.0.
Summary: Openning of files with national characters from dolphin, krusader doesn't wor...
Status: RESOLVED DUPLICATE of bug 186038
Alias: None
Product: kdelibs
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-06 20:25 UTC by Marian Kyral
Modified: 2009-03-06 21:26 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
dolphin_kwrite.png (76.18 KB, image/png)
2009-03-06 20:26 UTC, Marian Kyral
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Kyral 2009-03-06 20:25:18 UTC
Version:            (using KDE 4.2.1)
OS:                Linux
Installed from:    Gentoo Packages

See http://bugs.gentoo.org/show_bug.cgi?id=261367

After upgrade Qt libraries to 4.5.0 I'm not able to open any file containing
Czech characters from dolphin or krusader.

Okular error: Unable to open file:///home/marian/dokumenty/T0002798_dvÄ.pdf
(File name is: T0002798_dvě.pdf)

Reproducible: Always

Steps to Reproduce:
1. Create file containing non English characters.
2. With Qt libraries 4.5.0_rc1 installed, opening of the file from dolphin/krusader works. 
3. Upgrade Qt libraries to version 4.5.0
4. Try to open the file from dolphin/krusader

Actual Results:  
Okular shows and error: Unable to open
file:///home/marian/dokumenty/T0002798_dvÄ.pdf

Kate, kwrite opens a new blank file with name: "test_dvÄ.txt"

Expected Results:  
Files with non English characters are opened correctly.

Upgrade to 4.2.1 doesn't help.
Comment 1 Marian Kyral 2009-03-06 20:26:28 UTC
Created attachment 31852 [details]
dolphin_kwrite.png

After double click on "unison_dvě.txt".
Comment 2 BerS 2009-03-06 20:52:03 UTC
Similar problem with Russian characters.
The problem is when opening file from Dolphin or Krusader or Kmail in Kwrite,
Kate, Okular, Gwenview.

Qt-4.5
KDE-4.2.1
Gentoo
Comment 3 Jonathan Thomas 2009-03-06 21:26:39 UTC

*** This bug has been marked as a duplicate of bug 186038 ***