Bug 185827 - The application KWin (kwin) crashed and caused the signal 11 (SIGSEGV).
Summary: The application KWin (kwin) crashed and caused the signal 11 (SIGSEGV).
Status: RESOLVED WORKSFORME
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Unspecified
: NOR crash (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: investigated, triaged
Depends on:
Blocks:
 
Reported: 2009-02-28 20:28 UTC by Todor Todorov
Modified: 2018-10-21 05:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Todor Todorov 2009-02-28 20:28:56 UTC
Version:            (using KDE 4.2.0)
Installed from:    Ubuntu Packages

All windows crashed during alt-tab

This backtrace appears to be of no use.
This is probably because your packages are built in a way which prevents creation of proper backtraces, or the stack frame was seriously corrupted in the crash.

[Thread debugging using libthread_db enabled]
[New Thread 0xb648e6c0 (LWP 4313)]
0xb7fd3430 in __kernel_vsyscall ()
[Current thread is 0 (process 4313)]

Thread 1 (Thread 0xb648e6c0 (LWP 4313)):
#0  0xb7fd3430 in __kernel_vsyscall ()
#1  0xb695ff10 in nanosleep () from /lib/tls/i686/cmov/libc.so.6
#2  0xb695fd4e in sleep () from /lib/tls/i686/cmov/libc.so.6
#3  0xb7d6bd72 in ?? () from /usr/lib/libkdeui.so.5
#4  0xb7d6c734 in KCrash::defaultCrashHandler () from /usr/lib/libkdeui.so.5
#5  <signal handler called>
#6  0xb7ebafaa in KWin::WindowPaintData::WindowPaintData () from /usr/lib/libkwineffects.so.1
#7  0xb494618c in ?? () from /usr/lib/kde4/kwin4_effect_builtins.so
#8  0xb4949462 in ?? () from /usr/lib/kde4/kwin4_effect_builtins.so
#9  0xb7f81d0f in ?? () from /usr/lib/libkdeinit4_kwin.so
#10 0xb494d10d in ?? () from /usr/lib/kde4/kwin4_effect_builtins.so
#11 0xb7f81d0f in ?? () from /usr/lib/libkdeinit4_kwin.so
#12 0xb497a6b6 in ?? () from /usr/lib/kde4/kwin4_effect_builtins.so
#13 0xb7f81d0f in ?? () from /usr/lib/libkdeinit4_kwin.so
#14 0xb7eb9046 in KWin::Effect::paintScreen () from /usr/lib/libkwineffects.so.1
#15 0xb7f81d0f in ?? () from /usr/lib/libkdeinit4_kwin.so
#16 0xb7eb9046 in KWin::Effect::paintScreen () from /usr/lib/libkwineffects.so.1
#17 0xb7f81d0f in ?? () from /usr/lib/libkdeinit4_kwin.so
#18 0xb7eb9046 in KWin::Effect::paintScreen () from /usr/lib/libkwineffects.so.1
#19 0xb7f81d0f in ?? () from /usr/lib/libkdeinit4_kwin.so
#20 0xb7eb9046 in KWin::Effect::paintScreen () from /usr/lib/libkwineffects.so.1
#21 0xb7f81d0f in ?? () from /usr/lib/libkdeinit4_kwin.so
#22 0xb49a3bd0 in ?? () from /usr/lib/kde4/kwin4_effect_builtins.so
#23 0xb7f81d0f in ?? () from /usr/lib/libkdeinit4_kwin.so
#24 0xb7eb9046 in KWin::Effect::paintScreen () from /usr/lib/libkwineffects.so.1
#25 0xb7f81d0f in ?? () from /usr/lib/libkdeinit4_kwin.so
#26 0xb497e3dd in ?? () from /usr/lib/kde4/kwin4_effect_builtins.so
#27 0xb7f81d0f in ?? () from /usr/lib/libkdeinit4_kwin.so
#28 0xb7f6df10 in ?? () from /usr/lib/libkdeinit4_kwin.so
#29 0xb7f79e7a in ?? () from /usr/lib/libkdeinit4_kwin.so
#30 0xb7f691f6 in ?? () from /usr/lib/libkdeinit4_kwin.so
#31 0xb7f04b5d in ?? () from /usr/lib/libkdeinit4_kwin.so
#32 0xb6e62a60 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#33 0xb6e637e2 in QMetaObject::activate () from /usr/lib/libQtCore.so.4
#34 0xb6e9d7a7 in QTimer::timeout () from /usr/lib/libQtCore.so.4
#35 0xb6e6940e in QTimer::timerEvent () from /usr/lib/libQtCore.so.4
#36 0xb6e5d53f in QObject::event () from /usr/lib/libQtCore.so.4
#37 0xb70de8ec in QApplicationPrivate::notify_helper () from /usr/lib/libQtGui.so.4
#38 0xb70e672e in QApplication::notify () from /usr/lib/libQtGui.so.4
#39 0xb7cfbfed in KApplication::notify () from /usr/lib/libkdeui.so.5
#40 0xb7f1a16d in ?? () from /usr/lib/libkdeinit4_kwin.so
#41 0xb6e4de61 in QCoreApplication::notifyInternal () from /usr/lib/libQtCore.so.4
#42 0xb6e7bd81 in ?? () from /usr/lib/libQtCore.so.4
#43 0xb6e78520 in ?? () from /usr/lib/libQtCore.so.4
#44 0xb66776f8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#45 0xb667ada3 in ?? () from /usr/lib/libglib-2.0.so.0
#46 0xb667af61 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#47 0xb6e78478 in QEventDispatcherGlib::processEvents () from /usr/lib/libQtCore.so.4
#48 0xb7178ea5 in ?? () from /usr/lib/libQtGui.so.4
#49 0xb6e4c52a in QEventLoop::processEvents () from /usr/lib/libQtCore.so.4
#50 0xb6e4c6ea in QEventLoop::exec () from /usr/lib/libQtCore.so.4
#51 0xb6e4eda5 in QCoreApplication::exec () from /usr/lib/libQtCore.so.4
#52 0xb70de767 in QApplication::exec () from /usr/lib/libQtGui.so.4
#53 0xb7f1e002 in kdemain () from /usr/lib/libkdeinit4_kwin.so
#54 0x08048732 in _start ()
#0  0xb7fd3430 in __kernel_vsyscall ()
Comment 1 Martin Flöser 2009-02-28 23:06:52 UTC
(In reply to comment #0)
> This backtrace appears to be of no use.
> This is probably because your packages are built in a way which prevents
> creation of proper backtraces, or the stack frame was seriously corrupted in
> the crash.
Please install the debug packages and paste a correct stacktrace after reproducing the crash. For Ubuntu it's kdebase-workspace-dbg and the dependencies. You might also find more information here: http://techbase.kde.org/Development/Tutorials/Debugging/How_to_create_useful_crash_reports

Please also tell us which effect for alt+tab you are using. Is it possible that a window closed during alt+tab? It might be that this report is a duplicate.
Comment 2 Martin Flöser 2009-03-15 13:35:36 UTC
waiting for backtrace
Comment 3 Florian Kohlar 2009-05-27 16:49:27 UTC
for me it "accidentaly" crashed when i closed the "hardware drivers" window.

Anwendung: Jockey (), Signal SIGSEGV
0x00007fb5b8321d21 in nanosleep () from /lib/libc.so.6

Thread 1 (Thread 0x7fb5b92a76f0 (LWP 9747)):
[KCrash Handler]
#5  0x00007fb5b57276d4 in QWidget::metric () from /usr/lib/libQtGui.so.4
#6  0x00007fb5b58a0b1a in QFont::QFont () from /usr/lib/libQtGui.so.4
#7  0x00007fb5b56e93c4 in QWidgetPrivate::updateFont () from /usr/lib/libQtGui.so.4
#8  0x00007fb5b56e92fc in QWidgetPrivate::resolveFont () from /usr/lib/libQtGui.so.4
#9  0x00007fb5b56f4188 in QWidget::setParent () from /usr/lib/libQtGui.so.4
#10 0x00007fb5b56f4592 in QWidget::setParent () from /usr/lib/libQtGui.so.4
#11 0x00007fb5b56f9d46 in QWidgetAction::releaseWidget () from /usr/lib/libQtGui.so.4
#12 0x00007fb5b5ac9f2f in QMenu::~QMenu () from /usr/lib/libQtGui.so.4
#13 0x00007fb5b06aa93b in KMenu::~KMenu () from /usr/lib/libkdeui.so.5
#14 0x00007fb5b06575e3 in KSystemTrayIcon::~KSystemTrayIcon () from /usr/lib/libkdeui.so.5
#15 0x00007fb5b0da598e in sipKSystemTrayIcon::~sipKSystemTrayIcon () from /usr/lib/python2.6/dist-packages/PyKDE4/kdeui.so
#16 0x00007fb5b7bd2191 in QObjectPrivate::deleteChildren () from /usr/lib/libQtCore.so.4
#17 0x00007fb5b56ebbc2 in QWidget::~QWidget () from /usr/lib/libQtGui.so.4
#18 0x00007fb5b662154e in ?? () from /usr/lib/python2.6/dist-packages/PyQt4/QtGui.so
#19 0x00007fb5b65c7d18 in ?? () from /usr/lib/python2.6/dist-packages/PyQt4/QtGui.so
#20 0x00007fb5b6a39376 in ?? () from /usr/lib/python2.6/dist-packages/sip.so
#21 0x0000000000469bd5 in ?? ()
#22 0x000000000044d0f3 in ?? ()
#23 0x0000000000469c6b in ?? ()
#24 0x000000000044b967 in ?? ()
#25 0x000000000044df0d in PyDict_SetItem ()
#26 0x000000000044fc31 in _PyModule_Clear ()
#27 0x00000000004b77d6 in PyImport_Cleanup ()
#28 0x00000000004c44ad in Py_Finalize ()
#29 0x00000000004c3f1a in ?? ()
#30 0x00000000004c411d in PyErr_PrintEx ()
#31 0x00000000004c4ec7 in PyRun_SimpleFileExFlags ()
#32 0x00000000004189ce in Py_Main ()
#33 0x00007fb5b82985a6 in __libc_start_main () from /lib/libc.so.6
#34 0x0000000000417ae9 in _start ()
Comment 4 Martin Flöser 2009-05-27 17:29:09 UTC
(In reply to comment #3)
> for me it "accidentaly" crashed when i closed the "hardware drivers" window.
> 
> Anwendung: Jockey (), Signal SIGSEGV
This is jockey (or hardware drivers) which crashed. This has nothing to do with kwin and is not even a KDE application. Please report to Kubuntu devs at launchpad.net.
Comment 5 Florian Kohlar 2009-05-27 17:30:53 UTC
Okay, sorry about that.
Comment 6 Andrew Crouthamel 2018-09-19 04:38:02 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please mark the bug as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 7 Andrew Crouthamel 2018-10-21 05:07:18 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!