Bug 185718 - Enable bugzilla tags for tickets
Summary: Enable bugzilla tags for tickets
Status: RESOLVED INTENTIONAL
Alias: None
Product: bugs.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Unspecified
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Matt Rogers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-27 16:18 UTC by Juha Tuomala
Modified: 2009-03-25 03:47 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juha Tuomala 2009-02-27 16:18:50 UTC
Version:            (using KDE 4.2.0)
Installed from:    Fedora RPMs

The bugzilla seems to support tags:

  http://www.bugzilla.org/docs/tip/en/html/userpreferences.html
  > Enable tags for bugs - turn bug tagging on or off.

Today we were talking about KDE4 regressions and possibility to make a list of all such reports in bugs.kde.org that are regressions against KDE3. 

Someone suggested to use userspace to such, but that would be manually maintained references to the bugs.kde.org and go out of date quickly. We could also use such hours to clean the bugzilla itself.

If we could add such metadata into bugzilla itself, it would make whole lot easier to provide such listings just by SQL queries.

So we need an ability to add metadata tags into each entry and bugzilla seems to have that feature already. Please, consider switching it on.
Comment 1 Pino Toscano 2009-02-27 16:38:19 UTC
Like the existing "keywords" field?
Comment 2 Juha Tuomala 2009-02-27 17:24:30 UTC
Yes, exactly and it includes the 'regression' word, but regular logged in users cannot use it. My UI doesn't have that text input field. We have lot of tickets here that would need attention but people don't have rights to handle them.
Comment 3 Matt Rogers 2009-02-27 18:09:32 UTC
bugzilla 3.2 doesn't have this and i'm not running bugzilla CVS HEAD on a production system.
Comment 4 Matt Rogers 2009-02-27 18:13:22 UTC
ahh, but it's there in 3.2 as well.
Comment 5 Juha Tuomala 2009-02-27 18:31:25 UTC
I was told that keywords are used as part of release process so opening them up to everyone is out of the question. List of them:
  https://bugs.kde.org/describekeywords.cgi

Why not use milestones and bug dependencies from bz standard features list as that's what those are designed for?

For me as regular reporter, it's frustrating that lot of features are removed and when reports get outdated or have wrong version information etc - people don't have rights to put that information in there.

IMO it's clear that current rights management policy does not guarantee enough manpower to handle current report flow and we gradually build up a pile of invalid/outdated information which is no good for anyone.

KDE should open more bugzilla rights for logged in users. Content management works in wikipedia and don't see much difference in our user community with that.
Comment 6 Juha Tuomala 2009-02-27 18:37:12 UTC
https://bugs.kde.org/buglist.cgi?keywords=regression

List has 10 items, i guess it proves my point that there aren't enough eyes with rights to edit those keywords.

Such listings could also be linked into main page imo.
Comment 7 Juha Tuomala 2009-03-10 10:16:10 UTC
Any solution for this? Could we either open the keywords or enable tags?
Comment 8 Matt Rogers 2009-03-10 15:36:30 UTC
i'm not opening the keywords and i'm still investigating how tags work. have some patience please.
Comment 9 Matt Rogers 2009-03-10 20:55:15 UTC
Even if I enable tags for bugs in bugzilla, the tags set are only visible to the current user, and while useful, won't do what you want, so this is still a WONTFIX.
Comment 10 Juha Tuomala 2009-03-13 20:23:24 UTC
(In reply to comment #9)
> Even if I enable tags for bugs in bugzilla, the tags set are only visible to
> the current user, and while useful, won't do what you want, so this is still a
> WONTFIX.

Could you elabroate this:
- what the 'current user' stands for? One that has an account and has logged in?
- if that current user is logged in user, that's exactly what's needed.

I do log in and still cannot mark the regression anyhere else than into comments which is no good at all.
Comment 11 Matt Rogers 2009-03-24 03:05:05 UTC
the current user is the one that's currently logged in, yes. However, since these tags only apply for the current user, what use are they really other than for your own use?
Comment 12 Juha Tuomala 2009-03-24 08:00:56 UTC
Are you sure that they only apply to the current user and are not visible to the others? That would be the first time I see such implementation in any web based system that has a tag concept available.

I don't care is that tag, keyword or something else implemented on site. We need some tool for this and there is none.
Comment 13 Kevin Kofler 2009-03-24 15:24:59 UTC
Uh, keywords are already available. At least I get a "Keywords" field in that gray box. (But I've got developer access, so maybe the field is hidden to regular users.)
Comment 14 Juha Tuomala 2009-03-24 16:00:32 UTC
Kevin, for your info (which also reads in comments), that's where all this started and that's what this ticket is all about.
Comment 15 Matt Rogers 2009-03-25 03:47:56 UTC
yes, i'm sure. i tested it myself. Bugzilla isn't very web 2.0