Bug 185450 - crash while before files are displaied
Summary: crash while before files are displaied
Status: RESOLVED DUPLICATE of bug 182792
Alias: None
Product: kompare
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Kompare developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-24 17:34 UTC by Nadav Kavalerchik
Modified: 2009-02-24 18:21 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nadav Kavalerchik 2009-02-24 17:34:24 UTC
Version:           unknown (using 4.2.00 (KDE 4.2.0), Debian packages)
Compiler:          cc
OS:                Linux (x86_64) release 2.6.26-1-amd64

i tried to compare a local file with a remote (ftp) file using krusader and also invoking kompare as standalone. both crashed kompare before files were in view.

i have updated (debian experimental) several libraries a yesterday and i guess it has to do with that since it use to work just fine (as far as i can remember)

here is a (probably useless) crash log:

This backtrace appears to be of no use.
This is probably because your packages are built in a way which prevents creation of proper backtraces, or the stack frame was seriously corrupted in the crash.

(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 0x7fc03146e950 (LWP 7027)]
0x00007fc03e1c58d1 in nanosleep () from /lib/libc.so.6
[Current thread is 1 (Thread 0x7fc0413f6700 (LWP 7024))]

Thread 2 (Thread 0x7fc03146e950 (LWP 7027)):
#0  0x00007fc03e1eeb42 in select () from /lib/libc.so.6
#1  0x00007fc03e8b94e6 in QProcessManager::run (this=0x25ee860) at io/qprocess_unix.cpp:300
#2  0x00007fc03e7f27c2 in QThreadPrivate::start (arg=0x25ee860) at thread/qthread_unix.cpp:184
#3  0x00007fc03d4f1faa in start_thread (arg=<value optimized out>) at pthread_create.c:297
#4  0x00007fc03e1f52ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fc0413f6700 (LWP 7024)):
#0  0x00007fc03e1c58d1 in nanosleep () from /lib/libc.so.6
#1  0x00007fc03e1c56f7 in __sleep (seconds=<value optimized out>) at ../sysdeps/unix/sysv/linux/sleep.c:138
#2  0x00007fc03fefd519 in KCrash::startDrKonqi (argv=0x7fff4952e108, argc=17) at ../../kdeui/util/kcrash.cpp:412
#3  0x00007fc03fefde6a in KCrash::defaultCrashHandler (sig=11) at ../../kdeui/util/kcrash.cpp:337
#4  <signal handler called>
#5  QObjectPrivate::cleanConnectionLists (this=0x0) at kernel/qobject.cpp:301
#6  0x00007fc03e8f0606 in QMetaObject::activate (sender=0x2b76b10, from_signal_index=25, to_signal_index=25, argv=0x7fff4952e730) at kernel/qobject.cpp:3098
#7  0x00007fc031fa78ff in ?? () from /usr/lib/libkomparediff2.so.4
#8  0x00007fc031fa8da8 in ?? () from /usr/lib/libkomparediff2.so.4
#9  0x00007fc031fa9026 in ?? () from /usr/lib/libkomparediff2.so.4
#10 0x00007fc03e8f0592 in QMetaObject::activate (sender=0x2b76b10, from_signal_index=<value optimized out>, to_signal_index=10, argv=0x1) at kernel/qobject.cpp:3064
#11 0x00007fc03e87b2ff in QProcess::finished (this=0x0, _t1=1, _t2=QProcess::NormalExit) at .moc/release-shared/moc_qprocess.cpp:136
#12 0x00007fc03e8811de in QProcessPrivate::_q_processDied (this=0x2b113d0) at io/qprocess.cpp:713
#13 0x00007fc03e881291 in QProcess::qt_metacall (this=0x2b76b10, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff4952eb00) at .moc/release-shared/moc_qprocess.cpp:109
#14 0x00007fc03ecb5ebd in KProcess::qt_metacall (this=0x0, _c=1230169760, _id=44121872, _a=0x1) at ./kprocess.moc:62
#15 0x00007fc031fa8ff6 in ?? () from /usr/lib/libkomparediff2.so.4
#16 0x00007fc03e8f0592 in QMetaObject::activate (sender=0x2b2b860, from_signal_index=<value optimized out>, to_signal_index=4, argv=0x1) at kernel/qobject.cpp:3064
#17 0x00007fc03e92779e in QSocketNotifier::activated (this=0x0, _t1=23) at .moc/release-shared/moc_qsocketnotifier.cpp:83
#18 0x00007fc03e8f51e3 in QSocketNotifier::event (this=0x2b2b860, e=0x7fff4952f0c0) at kernel/qsocketnotifier.cpp:311
#19 0x00007fc03f21666d in QApplicationPrivate::notify_helper (this=0x25d9a40, receiver=0x2b2b860, e=0x7fff4952f0c0) at kernel/qapplication.cpp:4051
#20 0x00007fc03f21e85a in QApplication::notify (this=0x7fff4952f540, receiver=0x2b2b860, e=0x7fff4952f0c0) at kernel/qapplication.cpp:4016
#21 0x00007fc03fe97fab in KApplication::notify (this=0x7fff4952f540, receiver=0x2b2b860, event=0x7fff4952f0c0) at ../../kdeui/kernel/kapplication.cpp:307
#22 0x00007fc03e8dabbc in QCoreApplication::notifyInternal (this=0x7fff4952f540, receiver=0x2b2b860, event=0x7fff4952f0c0) at kernel/qcoreapplication.cpp:597
#23 0x00007fc03e904479 in socketNotifierSourceDispatch (source=0x25dd0e0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:208
#24 0x00007fc03a7fcaab in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#25 0x00007fc03a80026d in ?? () from /usr/lib/libglib-2.0.so.0
#26 0x00007fc03a80042b in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#27 0x00007fc03e9041ff in QEventDispatcherGlib::processEvents (this=0x25d5230, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:318
#28 0x00007fc03f2ae6cf in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:197
#29 0x00007fc03e8d9462 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 1230172896}) at kernel/qeventloop.cpp:144
#30 0x00007fc03e8d982d in QEventLoop::exec (this=0x7fff4952f320, flags={i = 1230172976}) at kernel/qeventloop.cpp:195
#31 0x00007fc03e8dbaf4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:875
#32 0x000000000040a5e5 in _start ()
Comment 1 Kevin Kofler 2009-02-24 17:38:00 UTC
Using Qt 4.5, right? This is already fixed in 4.2.1 and 4.3.

*** This bug has been marked as a duplicate of bug 182792 ***
Comment 2 Nadav Kavalerchik 2009-02-24 18:21:53 UTC
right :-(

i was to quick on the update trigger, me bad ;-)