Bug 185222 - Does not correctly work with nonlatin characters
Summary: Does not correctly work with nonlatin characters
Status: RESOLVED DUPLICATE of bug 186038
Alias: None
Product: kdelibs
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Aurelien Gateau
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-22 12:51 UTC by Dmitrij S. Kryzhevich
Modified: 2009-03-27 13:17 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitrij S. Kryzhevich 2009-02-22 12:51:45 UTC
Version:            (using KDE 4.2.0)
OS:                Linux
Installed from:    Fedora RPMs

Problem with Gwenview 2.2 (Fedora 10 x64_64, kdegraphics 4.2.0).

How to reproduce:
1) Create file or dir with nonlatin characters.
2) Open Konsole/Terminal/etc.
3a) "cd" to dir with interesting file.
3b) Add to filename full path.
4) Exec: gwenview filename.

Expected behaviour: open an image.
Current behaviour: open gwenview with error message "Could not open file".

Verified on Russian letters.
Comment 1 Dmitrij S. Kryzhevich 2009-02-22 13:20:16 UTC
Not gwenview problem, sorry. Looks like qt4.5 problem.
Comment 2 kostiagol 2009-02-23 18:52:39 UTC
Same problem here!
Ark, ksysguard, kwrite,(and propably other programs) russian folders and files can't open or no such file. And I had this problem before qt4.5, it was in kde4.0 already. I'we been thinking that it is my fault, reinstalled fresh linux, and nothing changed. It's not because of debian, or fedora, or qt4 at all, skype uses qt4, and many other non kde programs.

Debian amd64, KDE4.2 (yesterday upgraded to qt4.5) encoding - by default utf
Comment 3 Ben Boeckel 2009-02-24 09:27:31 UTC
I cannot confirm here (using rawhide packages). Cyrillic, African Scripts, and other non-latin characters work just fine here (both from konsole and dolphin).

Package list:
qt-4.5.0-0.3.rc1
kdelibs-4.2.0-13
kdegraphics-4.2.0-2
kdebase-4.2.0-5

FWIW, it also works on qt-4.4.3 on F10 here. Any other possible differences that may cause the problem?
Comment 4 Aurelien Gateau 2009-03-02 19:14:37 UTC
Does not seem related to Gwenview, reassigning to kdelibs.
Comment 5 duott 2009-03-15 13:19:10 UTC
Same here. It seems to be a gwenview problem after all - it fails to read files with cyrillic filenames while other KDE apps like dolphin, kate, okular work fine.

Ubuntu Jaunty, KDE 4.2, Gwenview 2.2.0
Comment 6 Dmitrij S. Kryzhevich 2009-03-16 06:06:53 UTC
Hm.. in my case, okular and kate do the same as gwenview.
Comment 7 Dmitrij S. Kryzhevich 2009-03-27 13:17:30 UTC

*** This bug has been marked as a duplicate of bug 186038 ***