Bug 185100 - Konqueror saves user password pairs depending on a site path and it shouldn't do that
Summary: Konqueror saves user password pairs depending on a site path and it shouldn't...
Status: RESOLVED DUPLICATE of bug 155391
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 4.2.0
Platform: Fedora RPMs Linux
: NOR normal with 13 votes (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-21 10:09 UTC by Artem S. Tashkinov
Modified: 2009-07-31 06:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Artem S. Tashkinov 2009-02-21 10:09:06 UTC
Version:           4.2.0 (using KDE 4.2.0)
OS:                Linux
Installed from:    Fedora RPMs

For example on this very site you can login at

https://bugs.kde.org/
https://bugs.kde.org/index.cgi?GoAheadAndLogIn=1
https://bugs.kde.org/wizard.cgi

and at every bug report page like
https://bugs.kde.org/show_bug.cgi?id=142342&GoAheadAndLogIn=1

Currently Konqueror will only remember credentials for any of these pages and won't offer them at all other pages. This is a bug. Konqueror should store user password pair only based on form input fields names.
Comment 1 Artem S. Tashkinov 2009-07-31 06:12:45 UTC
This seems like a duplicate of bug 131303.

Hm, it was filed three years ago ... and it now have at least 4 duplicates.
Comment 2 Raphael Kubo da Costa 2009-07-31 06:30:43 UTC

*** This bug has been marked as a duplicate of bug 155391 ***