Bug 184867 - Kget crashes when it is told to close
Summary: Kget crashes when it is told to close
Status: RESOLVED DUPLICATE of bug 191122
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: klocale (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Chusslove Illich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-19 00:26 UTC by Tony Clifton
Modified: 2009-05-24 21:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony Clifton 2009-02-19 00:26:00 UTC
Version:            (using KDE 4.1.4)
OS:                Linux
Installed from:    Fedora RPMs

I opened kget, then changed my mind about the download so I quit the programme, it crashed
producing the KDE Crash Handler

this is the report from that application
------------------------------------------
Application: KGet (kget), signal SIGABRT
[Current thread is 1 (Thread 0xb80b8770 (LWP 27292))]

Thread 1 (Thread 0xb80b8770 (LWP 27292)):
[KCrash Handler]
#6  0x00f62416 in __kernel_vsyscall ()
#7  0x00b4c460 in raise () from /lib/libc.so.6
#8  0x00b4de28 in abort () from /lib/libc.so.6
#9  0x00b89fed in __libc_message () from /lib/libc.so.6
#10 0x00b90da9 in malloc_consolidate () from /lib/libc.so.6
#11 0x00b9292d in _int_malloc () from /lib/libc.so.6
#12 0x00b94765 in malloc () from /lib/libc.so.6
#13 0x0204601d in qMalloc () from /usr/lib/libQtCore.so.4
#14 0x0209c52f in QVectorData::malloc () from /usr/lib/libQtCore.so.4
#15 0x02088237 in ?? () from /usr/lib/libQtCore.so.4
#16 0x0208833f in ?? () from /usr/lib/libQtCore.so.4
#17 0x0207e7e0 in ?? () from /usr/lib/libQtCore.so.4
#18 0x020879ec in QRegExp::operator= () from /usr/lib/libQtCore.so.4
#19 0x02087c1e in QRegExp::QRegExp () from /usr/lib/libQtCore.so.4
#20 0x04b5a892 in KuitSemanticsPrivate::finalizeVisualText (this=0x82dbaf8, final=@0xbffe3b9c, fmt=Kuit::Fmt::None, hadQtTag=false, hadAnyHtmlTag=false)
    at /usr/src/debug/kdelibs-4.2.0/kdecore/localization/kuitsemantics.cpp:1563
#21 0x04b5d5dd in KuitSemanticsPrivate::format (this=0x82dbaf8, text=@0xbffe3b9c, ctxt=@0xbffe3ba0) at /usr/src/debug/kdelibs-4.2.0/kdecore/localization/kuitsemantics.cpp:979
#22 0x04b5d619 in KuitSemantics::format (this=0x82da840, text=@0xbffe3b9c, ctxt=@0xbffe3ba0) at /usr/src/debug/kdelibs-4.2.0/kdecore/localization/kuitsemantics.cpp:1687
#23 0x04b38ef9 in KLocalizedStringPrivate::postFormat (this=0x82860b0, text=@0xbffe3ba4, lang=@0xbffe3bd0, lscr=@0xbffe3bc8, ctxt=@0xbffe3ba0)
    at /usr/src/debug/kdelibs-4.2.0/kdecore/localization/klocalizedstring.cpp:477
#24 0x04b3ace4 in KLocalizedStringPrivate::toString (this=0x82860b0, locale=0x82dca60) at /usr/src/debug/kdelibs-4.2.0/kdecore/localization/klocalizedstring.cpp:296
#25 0x04b3b344 in KLocalizedString::toString (this=0xbffe3c28) at /usr/src/debug/kdelibs-4.2.0/kdecore/localization/klocalizedstring.cpp:205
#26 0x00879655 in ?? () from /usr/lib/libkgetcore.so.4
#27 0x008775c4 in TransferTreeModel::headerData () from /usr/lib/libkgetcore.so.4
#28 0x0651f31f in QHeaderView::sectionSizeFromContents () from /usr/lib/libQtGui.so.4
#29 0x0651e556 in QHeaderView::sizeHint () from /usr/lib/libQtGui.so.4
#30 0x0654dbcf in QTreeView::updateGeometries () from /usr/lib/libQtGui.so.4
#31 0x06515726 in QAbstractItemView::qt_metacall () from /usr/lib/libQtGui.so.4
#32 0x06558b2a in QTreeView::qt_metacall () from /usr/lib/libQtGui.so.4
#33 0x08071aef in _start ()
Comment 1 Christoph Feck 2009-05-24 21:10:37 UTC
Thanks Tony for the backtrace. Do you remember which locale/translation files you used when that crashed occurred? Can you reproduce the crash in KDE 4.2.x or KDE 4.3 beta1, or using a newer Qt version (4.5)? There are some bug fixes regarding the code that caused this crash.
Comment 2 Chusslove Illich 2009-05-24 21:22:29 UTC
Cause of this has probably been fixed in 4.2 already, and if not, then for sure by the fix introduced for #191122. So closing as duplicate of it.

*** This bug has been marked as a duplicate of bug 191122 ***