Bug 184791 - Crash on launching from Krusader comparing two files
Summary: Crash on launching from Krusader comparing two files
Status: RESOLVED DUPLICATE of bug 182792
Alias: None
Product: kompare
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Unspecified
: NOR crash (vote)
Target Milestone: ---
Assignee: Kompare developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-18 15:31 UTC by René Krell
Modified: 2009-02-18 17:02 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description René Krell 2009-02-18 15:31:08 UTC
Version:           3.5.2 (using Devel)
Compiler:          gcc 
Installed from:    Compiled sources

Qt: 4.5.0-rc1
KDE: 4.2.00 (KDE 4.2.0) "release 99" (OpenSuSE 11.1 KDE 4.2 Factory)
Kompare: 3.5.2

Here is the backtrace:

Application: Kompare (kompare), signal SIGSEGV
[Current thread is 1 (Thread 0xb5a25920 (LWP 11700))]

Thread 2 (Thread 0xb419bb90 (LWP 11706)):
#0  0xffffe430 in __kernel_vsyscall ()
#1  0xb62e6411 in select () from /lib/libc.so.6
#2  0xb65de3b7 in QProcessManager::run (this=0x8079488) at io/qprocess_unix.cpp:300
#3  0xb650c71e in QThreadPrivate::start (arg=0x8079488) at thread/qthread_unix.cpp:184
#4  0xb64aa1b5 in start_thread () from /lib/libpthread.so.0
#5  0xb62ed3be in clone () from /lib/libc.so.6

Thread 1 (Thread 0xb5a25920 (LWP 11700)):
[KCrash Handler]
#6  QObjectPrivate::cleanConnectionLists (this=0x0) at kernel/qobject.cpp:301
#7  0xb6616c28 in QMetaObject::activate (sender=0x81ee4c0, from_signal_index=25, to_signal_index=25, argv=0xbfdf513c) at kernel/qobject.cpp:3098
#8  0xb6618332 in QMetaObject::activate (sender=0x81ee4c0, m=0xb7fafa80, local_signal_index=0, argv=0xbfdf513c) at kernel/qobject.cpp:3136
#9  0xb7f94729 in ?? () from /usr/lib/libkomparediff2.so.4
#10 0xb7f94a75 in ?? () from /usr/lib/libkomparediff2.so.4
#11 0xb7f94b52 in ?? () from /usr/lib/libkomparediff2.so.4
#12 0xb6616bb8 in QMetaObject::activate (sender=0x81ee4c0, from_signal_index=10, to_signal_index=10, argv=0xbfdf5268) at kernel/qobject.cpp:3064
#13 0xb6618332 in QMetaObject::activate (sender=0x81ee4c0, m=0xb66f5e8c, local_signal_index=2, argv=0xbfdf5268) at kernel/qobject.cpp:3136
#14 0xb659d589 in QProcess::finished (this=0x81ee4c0, _t1=1, _t2=QProcess::NormalExit) at .moc/release-shared/moc_qprocess.cpp:136
#15 0xb65a3994 in QProcessPrivate::_q_processDied (this=0x81923f0) at io/qprocess.cpp:713
#16 0xb65a3a4b in QProcess::qt_metacall (this=0x81ee4c0, _c=QMetaObject::InvokeMetaMethod, _id=13, _a=0xbfdf540c) at .moc/release-shared/moc_qprocess.cpp:109
#17 0xb6825aca in KProcess::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkdecore.so.5
#18 0xb7f94b1a in ?? () from /usr/lib/libkomparediff2.so.4
#19 0xb6616bb8 in QMetaObject::activate (sender=0x817c560, from_signal_index=4, to_signal_index=4, argv=0xbfdf540c) at kernel/qobject.cpp:3064
#20 0xb6618332 in QMetaObject::activate (sender=0x817c560, m=0xb66f78b0, local_signal_index=0, argv=0xbfdf540c) at kernel/qobject.cpp:3136
#21 0xb66528d3 in QSocketNotifier::activated (this=0x817c560, _t1=16) at .moc/release-shared/moc_qsocketnotifier.cpp:83
#22 0xb661b917 in QSocketNotifier::event (this=0x817c560, e=0xbfdf57c0) at kernel/qsocketnotifier.cpp:311
#23 0xb6ad365c in QApplicationPrivate::notify_helper (this=0x8075d88, receiver=0x817c560, e=0xbfdf57c0) at kernel/qapplication.cpp:4051
#24 0xb6adb91e in QApplication::notify (this=0xbfdf5a3c, receiver=0x817c560, e=0xbfdf57c0) at kernel/qapplication.cpp:3598
#25 0xb756b92d in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#26 0xb660091b in QCoreApplication::notifyInternal (this=0xbfdf5a3c, receiver=0x817c560, event=0xbfdf57c0) at kernel/qcoreapplication.cpp:594
#27 0xb662c5da in socketNotifierSourceDispatch (source=0x8078c58) at kernel/qcoreapplication.h:208
#28 0xb5df79a8 in IA__g_main_context_dispatch (context=0x8078098) at gmain.c:2144
#29 0xb5dfb063 in g_main_context_iterate (context=0x8078098, block=1, dispatch=1, self=0x8075ed0) at gmain.c:2778
#30 0xb5dfb221 in IA__g_main_context_iteration (context=0x8078098, may_block=1) at gmain.c:2841
#31 0xb662c348 in QEventDispatcherGlib::processEvents (this=0x8075e88, flags={i = -1075881704}) at kernel/qeventdispatcher_glib.cpp:318
#32 0xb6b73195 in QGuiEventDispatcherGlib::processEvents (this=0x8075e88, flags={i = -1075881656}) at kernel/qguieventdispatcher_glib.cpp:197
#33 0xb65fef3a in QEventLoop::processEvents (this=0xbfdf59c0, flags={i = -1075881592}) at kernel/qeventloop.cpp:144
#34 0xb65ff37a in QEventLoop::exec (this=0xbfdf59c0, flags={i = -1075881528}) at kernel/qeventloop.cpp:195
#35 0xb6601829 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:872
#36 0xb6ad34d7 in QApplication::exec () at kernel/qapplication.cpp:3526
#37 0x0805038d in _start ()
Comment 1 Kevin Kofler 2009-02-18 17:02:32 UTC

*** This bug has been marked as a duplicate of bug 182792 ***