Bug 184665 - Amarok crashes on connection change when playing a stream
Summary: Amarok crashes on connection change when playing a stream
Status: RESOLVED DUPLICATE of bug 184630
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-17 15:36 UTC by Eelko Berkenpies
Modified: 2009-02-17 16:39 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Amarok crash report (13.95 KB, application/octet-stream)
2009-02-17 15:39 UTC, Eelko Berkenpies
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eelko Berkenpies 2009-02-17 15:36:29 UTC
Version:           2.0SVN (using KDE 4.2.0)
OS:                Linux
Installed from:    Fedora RPMs

Amarok 2 SVN revision 926795 crashes when you are switching connections while you're playing a (Shoutcast) stream.

Quite easy to reproduce for me;

1. Make sure Amarok is playing a (Shoutcast) stream.
2. Change the connection you are using (if possible, I'm using NetworkManager to switch between 2 different gateways).
3. Wait until the buffer is empty and then Amarok crashes.

I'm not sure what the expected result should be. Either Amarok should catch up the stream again for fail with an error message.

This might be related to bug #180339 but I'm not too sure about that. That's why I've chosen to open a different BR.
Comment 1 Eelko Berkenpies 2009-02-17 15:39:06 UTC
Created attachment 31402 [details]
Amarok crash report

The report that has been generated.
Comment 2 Mark Kretschmann 2009-02-17 16:39:16 UTC
Surprisingly, this report appears to be a dupe of a report about something completely different, but with the same backtrace.

So it's probably the same bug at work, in Systray.cpp. I'm gonna close this one as a dupe and will try to fix.


PS: Please don't attach backtraces, but paste them directly (makes it easier to search).

*** This bug has been marked as a duplicate of bug 184630 ***