Bug 184576 - High CPU usage when used with Qt 4.5 rc1 or switching Qt versions
Summary: High CPU usage when used with Qt 4.5 rc1 or switching Qt versions
Status: RESOLVED DUPLICATE of bug 178228
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kded (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Faure
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-17 00:52 UTC by Joe Morris
Modified: 2010-01-16 12:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Morris 2009-02-17 00:52:46 UTC
Version:           kdelibs4-4.2.0-97.1 (using KDE 4.2.0)
OS:                Linux
Installed from:    SuSE RPMs

When upgrading to Qt 4.5 rc1, i noticed my CPU was pegged because of high kded4 usage.  I logged out, cleaned out tmp, cache, and socket (noticed ksyscoca link was orphaned), then logged in again.  It fixed the problem.  I learned via the opensuse web site and mailing list kde 4.2 should have Qt 4.4, which I "downgraded" to today (from the update repo), I had the same issue, which repeating the same action again fixed this issue.  So there must be something incompatible left over in the user files.  After cleaning them out, it works fine.
Comment 1 Joe Morris 2009-02-17 00:56:34 UTC
Oops, hardware details, Sempron 3100 x86_64 running openSUSE 11.1, ATI 9200 using radeon oss driver, though I'm not sure these are needed in this case.
Comment 2 Will Stephenson 2009-02-19 09:34:40 UTC
Do you know which process was eating 100% CPU?
Comment 3 Joe Morris 2009-02-19 10:54:47 UTC
I believe it was kded4, and it was actually about 97% CPU, and raised the CPU temp by 10-14 C from the norm.
Comment 4 David Faure 2009-02-19 12:27:41 UTC
Yes, it was kded4, I had the same bug here the day I upgraded qt-copy to 4.5-rc1. I tried to look into what kded was doing, but it was always in the glib event processing, I couldn't make sense of it. And restarting KDE fixed the problem. I don't think there is much we can do about this bug, if it's a one-time-only upgrade bug. I haven't had it since...
Comment 5 David Faure 2009-02-19 14:05:32 UTC

*** This bug has been marked as a duplicate of bug 178228 ***
Comment 6 David Faure 2010-01-16 12:07:08 UTC
SVN commit 1075552 by dfaure:

Fix 100% CPU usage due to a startTimer(0) that was never stopped; this could
happen if the timer was started twice, so m_timerId was overwritten, and the first
timer ID never recognized. It's much much simpler to use deleteLater: no risk of forgetting
the deletion and no risk of timers running forever. It means using QWeakPointer to notice
when it got deleted, though.
CCMAIL: kretz@kde.org

I'm not sure which of the "kded uses 100% cpu" bugs this really fixes; maybe all,
or maybe just the one that talks about phonon specifically...
Fixed for: 4.4
BUG: 202744
CCBUG: 178228
CCBUG: 184576
CCBUG: 217364
CCBUG: 220047


 M  +16 -34    hardwaredatabase.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1075552