Bug 184556 - Pager plasmoid draws outlines for minimized windows
Summary: Pager plasmoid draws outlines for minimized windows
Status: RESOLVED DUPLICATE of bug 189435
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-misc (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-16 21:45 UTC by Stephan Sokolow
Modified: 2009-04-28 10:04 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Problem screenshot (594.12 KB, image/png)
2009-02-17 23:22 UTC, Stephan Sokolow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Sokolow 2009-02-16 21:45:18 UTC
Version:           unknown (using 4.2.00 (KDE 4.2.0), Gentoo)
Compiler:          x86_64-pc-linux-gnu-gcc
OS:                Linux (x86_64) release 2.6.25-gentoo-r7-20080501

The pager plasmoid draws window outlines even if the windows in question are minimized. This becomes more and more bothersome for the user as the number of minimized windows increases.
Comment 1 FiNeX 2009-02-17 14:24:40 UTC
Hi! Can you provide a screenshot of the problem too?
Comment 2 Stephan Sokolow 2009-02-17 23:22:12 UTC
Created attachment 31424 [details]
Problem screenshot

The panel with the pager is in the top-right corner. Note how the pager is showing two windows in the left half of the active desktop despite one being minimized.
Comment 3 Martin Flöser 2009-04-26 21:17:53 UTC
@Stephan: have you by any chance set "keep window thumbnails" to allways in KWin's advanced desktop effects settings tab?
Comment 4 Stephan Sokolow 2009-04-27 04:22:54 UTC
Yes, actually. Is there supposed to be a relation or are you just removing variables?
Comment 5 Aaron J. Seigo 2009-04-27 11:03:37 UTC
kwin probably keeps them mapped and so the pager paints them. passing to kwin for comments.
Comment 6 Martin Flöser 2009-04-27 11:37:46 UTC
So could you please try if changing to "only for shown windows" or "never" solves the problem?
Comment 7 Stephan Sokolow 2009-04-28 02:00:18 UTC
Yeah, it does fix it... but I'll keep it on "Always" because the pager showing minimized windows is not that big a deal right now.
Comment 8 Martin Flöser 2009-04-28 10:04:41 UTC

*** This bug has been marked as a duplicate of bug 189435 ***