Bug 183763 - Kwin crashes when a GTK window closes and the user attempts to switch windows
Summary: Kwin crashes when a GTK window closes and the user attempts to switch windows
Status: RESOLVED DUPLICATE of bug 179865
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR crash with 1 vote (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-09 10:51 UTC by Marc de Bruijn
Modified: 2009-02-09 11:54 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marc de Bruijn 2009-02-09 10:51:52 UTC
Version:           4.2.00 (using KDE 4.2.0)
OS:                Linux
Installed from:    Debian testing/unstable Packages

When a window is closed and I attempt to switch applications while that process is handled Kwin crashes

I have this primarily with GTK applications (Synaptic opens and closes windows automatically when updating or installing, for example), but it's possible it happens with Qt ones as well. GTK applications are a bit slower, while Qt ones close nearly instantaneous, which might explain why I have this problem only with GTK applications.

Kwin respawns after crashing, which is quite nice, considering opening and closing windows can happen a lot during a session.

I got this backtrace (it's... err... rather short):

Application: KWin (kwin), signal SIGSEGV

Thread 1 (Thread 0xb63ff700 (LWP 5772)):
#0  0xb7f08424 in __kernel_vsyscall ()
#1  0xb7d7bed0 in nanosleep () from /lib/i686/cmov/libc.so.6
#2  0xb7d7bd0f in sleep () from /lib/i686/cmov/libc.so.6
#3  0xb7ba0128 in ?? () from /usr/lib/libkdeui.so.5
#4  0x00000000 in ?? ()
Comment 1 Martin Flöser 2009-02-09 11:31:36 UTC
I think that this is a duplicate of bug #179865. But to be sure: are you using desktop effects and an effect for alt+tab? Boxswitch or coverswitch?
Comment 2 Marc de Bruijn 2009-02-09 11:33:11 UTC
It could be. I'm using desktop effects and Box switch for Alt+Tab.
Comment 3 Martin Flöser 2009-02-09 11:54:53 UTC

*** This bug has been marked as a duplicate of bug 179865 ***