Bug 183711 - allow "pretagging" during image viewing by pressing a key
Summary: allow "pretagging" during image viewing by pressing a key
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Tags-Engine (show other bugs)
Version: 0.10.0
Platform: unspecified Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-08 18:10 UTC by simon
Modified: 2022-01-22 17:31 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description simon 2009-02-08 18:10:02 UTC
Version:           0.10.0-rc2 (using 4.2.61 (KDE 4.2.61 (KDE 4.3 >= 20090127)), Gentoo)
Compiler:          x86_64-pc-linux-gnu-gcc
OS:                Linux (x86_64) release 2.6.26-tuxonice

hi,

in order to tag alot of files, there is a feature missing which i found ultraconvenient implemented in kphotoalbum.
basically it allows you to press a key during a slideshow/viewing images fullscreen to set or unset a tag like "A" "B" "C" and so on.

later you can easily map the "A" to "Person/Alice" or whatever.

a short demo can be found at http://ktown.kde.org/kphotoalbum/videos/tour4.html

this was a real killerfeature as it allows you to tag images during viewing and i really miss this in digikam - what do you all think?
Comment 1 Johannes Wienke 2009-10-22 02:11:47 UTC
Wasn't there a plan about color labels for images? Maybe this could be a way to achieve this, too.
Comment 2 caulier.gilles 2009-10-22 08:51:26 UTC
This entry is not about color labels.

It's about to add shorcuts to Tags. there is already another entry in bugzilla. This one is a duplicate.

About color Label, look my comment :

https://bugs.kde.org/show_bug.cgi?id=152424#c29

Gilles Caulier
Comment 3 caulier.gilles 2009-10-22 08:54:18 UTC

*** This bug has been marked as a duplicate of bug 114465 ***
Comment 4 Johannes Wienke 2009-10-22 10:59:04 UTC
Gilles,

I thought about a alternative workflow that would keep Tags as a somewhat "stable" annotation, whereas color labels are more for working purposes. You could use color labels for "pre-tagging" and afterwarts provide a converter from color labels to tags. This would ensure that your tag-collection doesn't grow up with left-over entries in the form "A", "B", "C"... from this working stage.
Comment 5 caulier.gilles 2022-01-22 17:31:38 UTC
Fixed with https://bugs.kde.org/show_bug.cgi?id=114465