Bug 183684 - Compositing does not clear the graphics card memory
Summary: Compositing does not clear the graphics card memory
Status: RESOLVED DUPLICATE of bug 170462
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-08 14:44 UTC by Alex
Modified: 2009-02-08 17:11 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex 2009-02-08 14:44:15 UTC
Version:            (using KDE 4.2.0)
OS:                Linux
Installed from:    Debian testing/unstable Packages

Images from Compositing seem to stay in the graphic card RAM. If you logout and login again, and click on the splash-screen (so the splash goes away), you can see a mosaic of images and other screen parts from the previous session. It seems there is not possiblity to clear the Video-RAM to prevent this. This may be a privacy issue on shared systems, and its just unbeautiful for all others.

I'm using nvidia nonfree-driver NVIDIA-Linux-x86_64-180.22-pkg2.run
Comment 1 lucas 2009-02-08 17:11:49 UTC
What you are experiencing is a distribution-specific patch bug. Further details are available in bug 170462.

*** This bug has been marked as a duplicate of bug 170462 ***