Bug 183681 - CRASH Konqueror signal SIGABRT if closed too soon if run as super user
Summary: CRASH Konqueror signal SIGABRT if closed too soon if run as super user
Status: RESOLVED DUPLICATE of bug 151453
Alias: None
Product: konqueror
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Mandriva RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-02-08 13:55 UTC by Tony White
Modified: 2009-02-21 23:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tony White 2009-02-08 13:55:09 UTC
Version:           4.2.00 (using KDE 4.2.0)
OS:                Linux
Installed from:    Mandriva RPMs

Konqueror
Version 4.2.00 (KDE 4.2.0)
Using KDE 4.2.00 (KDE 4.2.0)

If I use : sudo konqueror
Then go, Oops I didn't want to do that and try to close konqueror as soon as it starts, It crashes in this way :

Application: Konqueror (konqueror), signal SIGABRT
[Current thread is 1 (Thread 0xb5ec16d0 (LWP 3906))]

Thread 2 (Thread 0xb1e1cb90 (LWP 3916)):
#0  0xffffe424 in __kernel_vsyscall ()
#1  0xb7e134d1 in select () from /lib/i686/libc.so.6
#2  0xb710257c in ?? () from /usr/lib/libQtCore.so.4
#3  0xb702b8bf in ?? () from /usr/lib/libQtCore.so.4
#4  0xb6551315 in start_thread () from /lib/i686/libpthread.so.0
#5  0xb7e1b25e in clone () from /lib/i686/libc.so.6

Thread 1 (Thread 0xb5ec16d0 (LWP 3906)):
[KCrash Handler]
#6  0xffffe424 in __kernel_vsyscall ()
#7  0xb7d68c00 in raise () from /lib/i686/libc.so.6
#8  0xb7d6a668 in abort () from /lib/i686/libc.so.6
#9  0xb7d61b5e in __assert_fail () from /lib/i686/libc.so.6
#10 0xb3ecb9cb in KHTMLGlobal::finalCheck () from /usr/lib/libkhtml.so.5
#11 0xb45440bd in ?? () from /usr/lib/kde4/libkhtmlpart.so
#12 0xb713d878 in QObjectCleanupHandler::clear () from /usr/lib/libQtCore.so.4
#13 0xb713d8d1 in QObjectCleanupHandler::~QObjectCleanupHandler () from /usr/lib/libQtCore.so.4
#14 0xb7425d4d in ?? () from /usr/lib/libkdecore.so.5
#15 0xb7300d69 in ?? () from /usr/lib/libkdecore.so.5
#16 0xb7d6bcd9 in exit () from /lib/i686/libc.so.6
#17 0xb6838ef8 in ?? () from /usr/lib/libQtGui.so.4
#18 0xb7670859 in KApplication::xioErrhandler () from /usr/lib/libkdeui.so.5
#19 0xb7670894 in ?? () from /usr/lib/libkdeui.so.5
#20 0xb7b92fba in _XIOError () from /usr/lib/libX11.so.6
#21 0xb7b9b3b5 in ?? () from /usr/lib/libX11.so.6
#22 0x097261d0 in ?? ()
#23 0x000003ab in ?? ()
#24 0xbfa9e5f0 in ?? ()
#25 0xbfa9e5ec in ?? ()
#26 0x00000008 in ?? ()
#27 0x00000000 in ?? ()

Obviously the solution is to not try to close it straight way and wait for it to load but I thought providing the crash information would be helpful.
Comment 1 Nicolas L. 2009-02-08 22:07:10 UTC
can you install the debug packages and paste the backtrace again ? ( qt4-debug kdelibs4-debug kdebase4-workspace4-debug kdebase4-runtime-debug kdebase4-debug )
Comment 2 Maksim Orlovich 2009-02-21 23:19:08 UTC

*** This bug has been marked as a duplicate of bug 151453 ***